Jump to content
Welcome to our new Citrix community!
  • 0

detach SR


jamie mwanza

Question

Hello,

I am failing to detach a Storage Repository. I am using Xenserver 7.6 that is attached to a Dell EMC Unity 300. I want to detach this storage for purposes of attaching it to another pool but all efforts have failed. I am not getting the option to detach it. The following is what i have tried so far:

 

In the console i have ran the command:

#ps -aux | -1 <SR uuid>

found a process there and killed it. Still did not work.

I tried to destroy the pbd but i am getting the follwing response:

[root@datacenter2 ~]# xe pbd-destroy uuid=6c4e30c5-e136-bace-36f7-b1ef57fe7184
You attempted an operation that was not allowed.
reason: PBD is currently attached

# xe pbd-unplug uuid=a4034599-959a-7527-2083-879df474b6ac
This operation cannot be performed because this VDI is in use by some other operation
vdi: b24bb974-1258-4fee-9a10-2a4968b2111c (SQL-EDM-BAK)
operation: <unknown>

 

Done toolstack restart but still nothing.

I have done a host restart still nothing.

What am i missing??

Link to comment

4 answers to this question

Recommended Posts

There may be an active VM, in which case you'll have to find out which is active and use "xe vm-reset-powerstate uuid=(UUID-of-VM)" to make sure it's not active. No activity can be going on on the SR from any VMs or you won't be able to detach it. See which VM the VDI is attached to and try that.

 

-=Tobias

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...