Jump to content
Welcome to our new Citrix community!
  • 2

SDK error when launching apps from storefront


andrew ogiba

Question

Have a user with a macbook with OSX mojave on it. Everytime she tries to launch an app from our citrix  storefront it will come up with an error saying:

 

"The SDK context supplied is not valid for the function called. Contact your help desk for assistance."

 

She was on workspace 1901 when this started happening. Tried  1812 then citrix receiver 12.9.1, 12.3 (along with the cert updater). We have tried safari and chrome. We updated the macbook to 10.14.3.  I have tried other solutions found online but i can't get this working. In our environment we have gotten plenty of other mojave macs working, this is the first one I cant seem to fix and first time seeing this SDK error.  Reading thru other articles online I saw deleting expired certs in the keychain may help.. Anyone ever done this? 

 

attached are logs from receiver

Citrix Workspace Updater_2019_03_12-16_16_55_11038.txt

CitrixViewer_2019_03_12-16_17_41_11127.txt

CitrixViewer_2019_03_12-16_35_29_1774.txt

ReceiverHelper_2019_03_12-16_16_35_10905.txt

ReceiverHelper_2019_03_12-16_35_01_1673.txt

Link to comment

13 answers to this question

Recommended Posts

  • 1

i had this issue on a user with mac OS 10.14.5, in order to fix it i had to download the SSL cert we used from Godaddy and then fully trust it.  

I had the issue with bot the receiver and workspace, fixing the SSL fixed both.

 

Trusting GoDaddy Root Certificate Authority

By default, Mac computers do not trust GoDaddy as a trusted certificate authority – the SSL certificate form is from GoDaddy and will need to be trusted for Citrix to work properly.

Symptom: The following error is displayed.

1.       Visit https://ssl-ccp.godaddy.com/repository

2.       Click the link to download gdig2.crt.pem

3.       Open the downloaded file, which automatically opens Keychain Access.

4.       Add the certificate to trusted certificate authority for the System

Find the newly installed certificate, double-click and set Trust to “Always Trust”
 

 

 

  • Like 1
Link to comment
  • 0
3 minutes ago, Shane Childs said:

Any help on this would be great as we are beginning to see this error on more and more MACs!!  Please help Citrix.

hey so after looking at about 15 threads online, i found the solution:

 

remove the wifi adapter then readd it. Reconnect to your wifi.

 

If that doesnt work i would look in keychain for expired citrix certs and remove

Link to comment
  • 0

So I remove the WiFi adapter and then re-added it back.  It worked to get me connected, but then as soon as I rebooted, the error came back.  I then tried removing all of the Citrix certificates as there were no expired ones. I then uninstalled Receiver and installed the latest Workspace, again removing the WiFi adapter and re adding.  I rebooted and then tried it again.  The app launched successfully, but then after another reboot the error returned.  It appears that I have to remove and then re-add the WiFi adapter anytime I want to launch an app.  Anything else anyone has that they have had success with?  

 

My users are physicians and do not have the time or patience to do this every time the need to launch an app. :( Any help is greatly appreciated. :)

Link to comment
  • 0

Bump. I apologize that I do not have anything to add other than I too am desperate for a more definitive solution. I have a user (a higher up executive) with the same error message. She is offsite so I do not have access to her Mac and she is quickly losing her patience. Having an exec poke around Wifi settings and adding/re-adding adapters is kind of out of the question.

Link to comment
  • 0
1 hour ago, Randy Wright1709160931 said:

Bump. I apologize that I do not have anything to add other than I too am desperate for a more definitive solution. I have a user (a higher up executive) with the same error message. She is offsite so I do not have access to her Mac and she is quickly losing her patience. Having an exec poke around Wifi settings and adding/re-adding adapters is kind of out of the question.

 

Desperate here to - cannot use my VDI desktop since a month now. Is there a permanent solution to this or do I have to throw my Mac out of the window and start over?

Link to comment
  • 0

Resolution!

 

I spent  4 hours working on this and I had found an article that was pointing to a "SOCKS" Proxy article but mine turned out to be a setting on the same screen which is labeled "Secure Web Proxy (HTTPS) which I turned off and it started working.  So in your "Network" area under Advanced, go to  the "Proxies" tab and make sure "SOCKS" and Secure Web Proxy are turned off. This article says that SOCKS may turn right back on(if that's your issue) so it may just be a one time fix until the pc is rebooted but at least it will work for a little while. I'm assuming turning off "Secure Web Proxy" doesn't turn itself back on which was my issue. Good luck! Here's an article with pictures: In case you've ever tried to call Citrix about issues, they will tell you that unless you have a paid support contract with them, they can't help you(that's real helpful). The article mentions Mojave but I upgraded the computer to Catalina which didn't help since the setting carried over, so you can experience it in either if the setting is set incorrectly.

 

https://support.wickr.com/hc/en-us/articles/360008497154-Disabling-proxy-settings-on-macOS

 

Link to comment
  • 0
On 7/29/2019 at 8:25 PM, michael spinka said:

i had this issue on a user with mac OS 10.14.5, in order to fix it i had to download the SSL cert we used from Godaddy and then fully trust it.  

I had the issue with bot the receiver and workspace, fixing the SSL fixed both.

 

Trusting GoDaddy Root Certificate Authority

By default, Mac computers do not trust GoDaddy as a trusted certificate authority – the SSL certificate form is from GoDaddy and will need to be trusted for Citrix to work properly.

Symptom: The following error is displayed.

1.       Visit https://ssl-ccp.godaddy.com/repository

2.       Click the link to download gdig2.crt.pem

3.       Open the downloaded file, which automatically opens Keychain Access.

4.       Add the certificate to trusted certificate authority for the System

Find the newly installed certificate, double-click and set Trust to “Always Trust”
 

 

 

This one worked for me. Thanks!

Link to comment
  • 0
On 11/22/2019 at 10:52 AM, Shawn Turner said:

Resolution!

 

I spent  4 hours working on this and I had found an article that was pointing to a "SOCKS" Proxy article but mine turned out to be a setting on the same screen which is labeled "Secure Web Proxy (HTTPS) which I turned off and it started working.  So in your "Network" area under Advanced, go to  the "Proxies" tab and make sure "SOCKS" and Secure Web Proxy are turned off. This article says that SOCKS may turn right back on(if that's your issue) so it may just be a one time fix until the pc is rebooted but at least it will work for a little while. I'm assuming turning off "Secure Web Proxy" doesn't turn itself back on which was my issue. Good luck! Here's an article with pictures: In case you've ever tried to call Citrix about issues, they will tell you that unless you have a paid support contract with them, they can't help you(that's real helpful). The article mentions Mojave but I upgraded the computer to Catalina which didn't help since the setting carried over, so you can experience it in either if the setting is set incorrectly.

 

https://support.wickr.com/hc/en-us/articles/360008497154-Disabling-proxy-settings-on-macOS

 

 

This worked for me!  Thank you for this.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...