Jump to content
Welcome to our new Citrix community!
  • 1

Trying to get the Citrix Workspace App to work


Gert Jan Lok

Question

Hi,

 

I'm having a very similar problem like the thread: https://discussions.citrix.com/topic/399778-workspace-ios-app-not-working-cr01-app-does-work/

I've also tried to set the portal theme to X1 instead of our custom one.

 

For some reason sometimes it works setting up an account on the Citrix Workspace App and sometimes it's not.

When it's not working the latest message I get from the app is "Cannot Add Account - All stores in the discovery document have been loaded".

 

Can anyone put me in the right direction to fix this problem?

 

Thanks in advance!

 

Greetings.

Link to comment

9 answers to this question

Recommended Posts

Hi Carl,

 

Thanks for the answer.

 

The Store URL is https://www.companyname.com/Citrix/Store

The Gateway is https://www.companyname.com/

If the /Citrix/Store part doesn't make any difference then both the URL's are the same.

 

So, if I understand it correctly I have to change the internal beacon to something that can't be resolved from the outside?

For example, an internal IP address?

 

Greetings,

 

Gert Jan

Link to comment
3 hours ago, Carl Stalhood1709151912 said:

Any internally reachable HTTP/HTTPS site is fine. Make sure it never goes down or else internal users won't be able to connect.

 

Do I have to reset any services after I made changes to the beacons?

I changed the internal beacon to a random internal ip-address (does exist!) but the Workspace App on my iPhone 6s stil gives me the same error I mentioned before.

 

Link to comment
On 15-3-2019 at 5:24 PM, Carl Stalhood1709151912 said:

Are you using the same FQDN/URL for both StoreFront Base URL and the Gateway? If so, then you need to change your Internal Beacon to something that is not reachable from the outside.

 

This did the trick indeed! After i Propogated Changes in the StoreFront Console!

 

Thanks!

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...