Jump to content
Welcome to our new Citrix community!
  • 0

Cant't boot Ubuntu 18.04 on Xenserver 7.6


Question

I installed Ubuntu 18.04 desktop on my pool. Tried to install it on 2 doms and on both of them the boot get stuck on a black screen with the following:

 

/dev/xvda1: clean, 178757/5242880 files, 2250246/20971008 blocks

 

I am able to ping the ip I set to the machine, so my guess is that the VM is not able to display the GUI. The sad thing is that I'm not even able to access grub, because when the machine boots up, it goes straight to a purple-ish screen (color of ubuntu) and then to the black screen with the text above.

 

Any ideas?

 

Thanks in advance.

Link to comment

16 answers to this question

Recommended Posts

  • 0
On 10/03/2019 at 3:45 PM, Tobias Kreidl said:

What version of XS are you running and for that version, is Ubuntu 18 on the supported guest OS list?

 

-=Tobias


Xenserver 7.6. Ubuntu 18 is on the support list. I was installing Ubuntu 18.04.2. Then I tried to install Ubuntu 18.04, and that worked. I was able to upgrade all the way to 18.04.2 with no further issues. But it is a bit odd that the installation of 18.04.2 kept failing.

 

Thanks anyway Tobias.

On 10/03/2019 at 3:56 PM, Alan Lantz said:

Install it on 2 doms? You mean you are exporting the VM and importing it to other XenServers ?

 

--Alan--

 

No Alan, I tried to install a new VM on 2 different doms, just to test if there was something wrong with my dom. Turned out was only Ubuntu 18.04.2 that was giving the boot error. Ubuntu 18.04 installed perfectly.

 

Thanks.

Link to comment
  • 0
1 hour ago, Alan Lantz said:

Is it just 32 bit or does 64 bit have the same issue ?

 

I think I'm just 18.04 at present.

 

--Alan--

 

Both 32 and 64 bits didn't boot here.

 

1 hour ago, Alan Lantz said:

Well, looks like I lied, I am 18.04.2 LTS.  I'm assuming I installed the 64 bit version.

 

--Alan--

 

Keep in mind that is the desktop version, not server. If you installed Ubuntu when it was 18.04 or 18.04.1, you can upgrade to 18.04.2 later with not problems.

Link to comment
  • 0
1 hour ago, Igor Voznyuk said:

Hello!

 

The same problem!

Ubuntu 18.04.2 LTR. XenServer 7.6

Ubuntu installed without any problems.

Afterinstallation reboot - and only string "/dev/xvda1: clean, ........."

Any ideas or solution?

 

Thank you.

Download Ubuntu 18.04, not Ubuntu 18.04.2.

It will boot fine, and from that you can make the usual apt upgrade to upgrade to 18.04.2

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...