Jump to content
Welcome to our new Citrix community!

StoreFront: Cannot join Servergroup - InvalidEventLogNameException


Recommended Posts

Hi guys

I'm really stumped on this.

I have a SF farm of three server on V 3.12 running and want to add a 4th server.

This server had already SF 2x installed, as it belonged to a different farm before.

So I uninstalled SF, re-installed SF 3.12 and tried to join the existing farm.

It fails with

An error occurred running the command: 'Set-DSJoinClusterEnvironment'
Exception of type 'Citrix.DeliveryServices.Framework.Deployment.Steps.Exceptions.InvalidEventLogNameException' was thrown.
At C:\Program Files\Citrix\Receiver StoreFront\Management\Cmdlets\ConfigurationReplicationModule.psm1:42 char:17
+     $instance = Add-DSConfigurationReplication -Folder $configurationReplication ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Exception of type 'Citrix.DeliveryServices.Framework.Deployment.Steps.Exceptions.InvalidEventLogNameException' was thrown.

Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces.Exceptions.PowerShellExecutionException, Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces, Version=3.12.0.0, Culture=neutral, PublicKeyToken=e8b77d454fa2a856
An error occurred running the command: 'Set-DSJoinClusterEnvironment'
Exception of type 'Citrix.DeliveryServices.Framework.Deployment.Steps.Exceptions.InvalidEventLogNameException' was thrown.
At C:\Program Files\Citrix\Receiver StoreFront\Management\Cmdlets\ConfigurationReplicationModule.psm1:42 char:17
+     $instance = Add-DSConfigurationReplication -Folder $configurationReplication ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 

I've already removed remaining Citrix directories under wwwroot and c:\program files, enabled Netbios, re-installed and rebooted several times.

It doesn't matter which of the existing farm servers I choose for joining.

 

Any help is very much appreciated

 

Link to comment
Share on other sites

Hi 

 

Have you tried to  remove server from an existing server group?

run & “$Env:PROGRAMFILES\Citrix\Receiver StoreFront\Scripts\ImportModules.ps1”

 Clear-DSConfiguration

Uninstall the storefront 

Delete the everything in C:\inetpub\wwwroot\Citrix

 

Reinstall the storefront and try to rejoin 

 

Thanks

Manoj

 

Link to comment
Share on other sites

5 minutes ago, Sabine Ludewig1709156713 said:

Hi

can't remove Servers from existing Group as they are in production mode and I don' want to break anything there

Ran clear-dsconfiguration without success

Uninstall - reboot- reinstall - no success

Delete c:\inetpub\wwwroot\Citrix - no success

also added netbios to NIC and checked rights in secpol.msc

What was the error message you were getting ?when you run the followings 

Ran clear-dsconfiguration without success

Uninstall - reboot- reinstall - no success

Delete c:\inetpub\wwwroot\Citrix - no success

 

 

Link to comment
Share on other sites

7 minutes ago, Sabine Ludewig1709156713 said:

No error messages when I run the uninstall procedures

By 'no success' I just meant that I still couldn't join the farm

 

any error when you were running 

run & “$Env:PROGRAMFILES\Citrix\Receiver StoreFront\Scripts\ImportModules.ps1”

 Clear-DSConfiguration

Link to comment
Share on other sites

clear-dsconfiguration

Reloading feature registry
Remove-DSFeatureInstance
Remove-DSClusterEnvironment
Reloading feature registry
Unknown feature class: ServiceMonitor
Unknown feature class: DomainServices
Remove the Subscriptions Store Service
Stopping Subscriptions Store Service
Removing Peer Name Resolution Service
Stopping Peer Resolution Service
Reloading feature registry
No Peer Name Resolution Service instance found to remove
Remove configuration replication
Reloading feature registry

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...