Jump to content
Welcome to our new Citrix community!
  • 3

Unable to uninstall Citrix Workspace App, so that it can be installed correctly

Peter Clews


Hi All,


I'm trying to uninstall Citrix Workspace App from a machine where it's installation was unsuccessful.  I uninstalled via the Citrix removal tool and I've run through the manual removal procedure for Citrix Receiver afterwards, as it gave the error below.  I've since rebooted and tried to reinstall it, but it states:


Unable to complete the installation.

We have detected a previous installation of Citrix Workspace App.

Please remove all previous installations before continuing.


However the only method of attempting removal now is via the command prompt command:


c:\temp>CitrixWorkspaceApp.exe /uninstall


But doing this gives the error:


Citrix Workspace App has stopped working.


If I click to view problem details it states:



Stopped working


Problem signature:

Problem Event Name: APPCRASH

Application Name: TrolleyExpress.exe

Application Version:

Application Timestamp:  5c0f57ff

Fault Module Name: KERNALBASE.dll

Fault Module Version:  6.1.7601.23367

Fault Module Timestamp:  589c9620

Exception Code: e0434f4d

Exception Offset: 0000c54f

OS Version: 6.1.7601.

Locale ID: 2057


Any ideas? (besides rebuilding the device!)






Link to comment

4 answers to this question

Recommended Posts

  • 0



for me the cleanup utility did absolutely nothing. It says that it's removing the program but afterwards everything is still there and the workspace even starts up again after reboot.

When trying to just uninstall, I get the error "Configuration Manager cannot be initialized".

Can't just try upgrading the thing either as it throws the same error. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...