Jump to content
Welcome to our new Citrix community!
  • 0

Integrated webcam not redirecting to Citrix session


Katrina Cruz

Question

Hi all,

 

Does Citrix allow redirection of all types of webcams, specifically integrated webcams? Or does it only allow / support redirection for certain types? I ask this because one of our clients have 300+ laptops that are the same model. None of them are able to use the webcam inside a Citrix XenApp 7.15 LTSR session.

 

No GPOs or Citrix policies are configured to block devices. In fact, the Citrix policy allows all (notice the "ALLOW: #"

https://pasteboard.co/I3lwIYf.png

 

If I use the same Citrix account that the client uses, but just on my own laptop, then webcam redirection into Citrix works. There are no GPOs applied to the client machines. Their webcam does not show up under Devices at all:

https://pasteboard.co/I3lxjRK.png

 

There are no drivers available for the webcam to be updated, either through Windows Update or through the vendor's website.

https://pasteboard.co/I3ly6IC.png

 

Lastly, I have tried RDP directly onto the server, making sure to tick all the redirection options. Webcam still not detected nor redirected.

 

We used the following site for testing:

https://www.onlinemictest.com/webcam-test/

 

And the same site works on the local machine. Just not in Citrix or RDP session.

 

I have also read this already:

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/us...

 

This is what's in the registry on the client machine:

 # Syntax is an ordered list of case insensitive rules where # is line comment
 #  and each rule is (ALLOW | DENY) : ( match )*
 #  and each match is (class|subclass|prot|vid|pid|rel) = hex-number
 # Maximum hex value for class/subclass/prot is FF, and for vid/pid/rel is FFFF
ALLOW: # Otherwise allow everything else
ALLOW:vid=056a pid=0315 class=03 # Wacom Intuos tablet
ALLOW:vid=056a pid=0314 class=03 # Wacom Intuos tablet
ALLOW:vid=056a pid=00fb class=03 # Wacom DTU tablet

 

Link to comment

7 answers to this question

Recommended Posts

  • 1

If you go in to your connection center while connected, Devices, do you see any devices that could be the webcam?  On my machine it is a long string of letters and numbers.  Next to it I can Switch to Generic to use it's generic driver.  When I do this, my webcam seems to show up for use in my XenApp 7.15 session.  Also what is showing on your Connections tab of the connection center?  I have had to check both items under Generic USB devices to get this going as well as set a regkey to force generic drivers for this to work without going to the connection center.


[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\GenericUSB\Devices]
"AutoRedirectVideo"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\GenericUSB\Devices]
"AutoRedirectVideo"=dword:00000001

 

  • Like 1
Link to comment
  • 0

Thanks for the replies and sorry for the slow update on my side.

 

@Martin, the webcam doesn't show up in the connected devices list (please see my screenshot in the original post). None of the devices shown are webcam related. You can also confirm the vid/pid of the webcam via devmgtmt.msc and it doesn't match any of the devices shown. Have already tried those reg keys, webcam still doesn't show up so I can't even switch the virtual channel from optimized to generic. If the user plugs an an external webcam, then it shows up just fine.

 

When logged into a Citrix session, we're simply using Chrome to load one of those webcam test sites, such as this:

https://www.onlinemictest.com/webcam-test/

Edited by Katrina Cruz
Link to comment
  • 0

First of all, this is your master resource for anything on Webcams :  https://support.citrix.com/article/CTX132764

We updated that CTX article last week with all the info you need to redirect the webcam to the VDA.

 

It is imperative you explicitly state the Workspace App version and OS, the VDA version and OS, what policies you configured, and the exact peripheral  and laptop brand /model.

If you dont, we cannot assist here.

 

Most important points are in Section 4:

 

 

1-Integrated webcams are generally not detected as USB devices in Device Manager on the Client, but rather under System devices.
If you go to Device Manager on the Client, then View->Sort by Connection, see if your cameras show up under a USB Hub device. If they do, then they should appear on Desktop Viewer. If they dont show under USB Hub, you cannot redirect them using Generic USB. You must use HDX Realtime Webcam Redirection.

 

2- If you are using a Workstation VDA (Windows 7 or 10), then you might need to do what is explained in Section 8.5
Whitelist the name of the executable of the unified communications app you are using.  REBOOT your VDA. Launch again.

 

I also recommend reading the entire troubleshooting section (section 8). 

 

IF you follow that article and tell us WHERE you are stuck, we can assist much better.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...