Jump to content
Welcome to our new Citrix community!
  • 0

HTML5 : Very poor performance


Joseph Robinson

Question

Good Afternoon,

 

I'm troubleshooting an issue in my environment, and I'm at a bit of a loss.

 

When launching applications via storefront web page, using the light client (html5), performance is absolutely horrible.  Keystrokes are not displayed immediately (takes 20-30 seconds), and graphical artifacts are left all over the screen.  Mouse movements are not delayed, but still leave the graphic artifacts.


For example, If I open Windows Explorer I can move the mouse around and open folders.  However, as I move the mouse over things that highlite, the highlite stays.  If I type cmd.exe into the address bar, I do not see anything.  However, if I type cmd.exe into the address bar and hit enter, a command prompt pops right up almost immediately.

 

If I switch to the locally installed Workspace App, everything is fine.  It only happens when using the HTML 5 client.

 

To Troubleshoot:

  • Removed netscaler and went direct to the storefront
  • Updated HTML5 client
  • Patched and rebooted storefront servers

 

I'm just not sure what else to look at ... any thoughts?

 

Thanks!

-joe

 

Link to comment

5 answers to this question

Recommended Posts

  • 0
5 hours ago, vikash said:

Hi @Joseph Robinson,

 

Good Day :)

 

Are you facing this issue across all the browsers or would this be specific to any one particular kind of browser.

Could you also please collect the logs, please follow this link - https://support.citrix.com/article/CTX217352

It provides instructions to collect logs for html5 receiver.

 

Regards,

Vikas Hiremath

 

I've tried it with all major browsers (IE, Edge, Chrome, Firefox) and they're all slow.  Multiple users, multiple workstations.  With NetScaler, without.   Logs are attached.

 

 

5 hours ago, vikash said:

Could you please try to upgrade to the latest version & also provide the version number you facing the issue with?

 

I was using an older HTML5 install (I don't recall the version), but to troubleshoot the problem, I updated to 19.2.0.4065 which is the latest at this time.  It didn't change anything.

 

 

After doing some more research, I found that this does not happen to when I run apps published to my 2012R2 machines running VDA 1808.  However, my 2016 machines running VDA 1811.  

Windows Explorer-2 (02-21-2019-10-29-33).txt

Link to comment
  • 0
49 minutes ago, Magnus Edholm1709153592 said:

 

I am facing exactly the same problem now. Did you find a solution to the problem?

 

I never actually got a fix.  I had a case open for a long time that made it's way all to the development team.  I ended up closing the case because... well, I won't get into the reasons.  Lets just say I didn't have the time to put into troubleshooting anymore even though Citrix was able to reproduce the issue.

 

If it helps, this is the last piece of information that made it's way back to me:

 

Current Status:

HTML5 Receiver with policy setting “Use Video Codec for Compression” set to “For actively changing regions”

We have confirmed that the H265 codec is not compatible with HTML5 Receiver.  That being said, the vda should fallback to H264 codec.

 

 

I ended up turning the 'For Actively Changing Regions' off so my users could use the HTML5 client.  

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...