Jump to content
Welcome to our new Citrix community!
  • 0

Grey Border Issue with HDX 3D Pro on Non-GPU Session

Paul Hite1709155384


We recently started converting our XD 7.6 Win7 environment running on XenServer over to XD 7.15 Win10 2016 LTSB running on vSphere. Both environments have NVIDIA GRID cards for GPU sessions. On the older environment, we managed a single image that had the NVIDIA drivers loaded and the published to two different pools - one with a GPU attached and the other without. This worked great for us.


Unfortunately I can't seem to get the same result from the 7.15 Win10 environment. Initially, the non-GPU sessions worked fine but the GPU sessions didn't seem to "see" the attached NVIDIA GPU (couldn't launch the NVIDIA control panel). I removed the NVIDIA drivers and VDA components and then reinstalled the NVIDIA drivers first, then the VDA bits with HDX 3D Pro, and the GPU sessions started working immediately. However, users connecting to a non-GPU session via Citrix Receiver are attached to the 'wrong' display - the VMware display specifically - and they are unable to resize the desktop and complain of grey "borders" on the sides of the screen (this doesn't seem to occur from our thin clients).


This issue is described in two support articles:




It's the same issue described by this post which seems to point blame at Win10:



The solution in both is just to 'disable HDX 3D Pro' by reinstalling the VDA without that component. That seems to suggest we need to maintain two different images - one HDX / GPU image, and one standard/non-GPU image. I'd like to avoid that if at all possible.


I've also seen suggestions that we need to remove the Display component of the VMware Tools installation. I've tried uninstalling the display driver with no improvement (it just changes the driver to Microsoft Basic Display Adapter). I have not tried uninstalling and reinstalling vmware tools, but I'd like to avoid a reverse image if I can.


Any idea how we can make this work or am I stuck with maintaining dual images?

Link to comment

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...