Jump to content
Welcome to our new Citrix community!
  • 0

display refresh issue with Chrome and VDA 7.15

Goran Jozic


we have been facing rather frustrating issue over the last month or so. We are running Windows 7 VDA 7.15 LTSR CU3 and the latest version of Google Chrome on non-persistent desktops using PVS 7.15.9.

Within last month or so users have been experiencing issue where screen would not refresh if Chrome runs in maximized window. any window or Start Menu that would be open on top of the Chrome window would just stay there after user tries to close it. If user were to move any window while maximized Chrome is in background we would see original "ghost" picture of the window and the window in the new position. Eventually after anywhere between 15-30 seconds picture would refresh and "ghost" images would disappear. 

now craziest thing about it is that we do not see the same behaviour if Chrome is running as a regular, non-maximized window. If Chrome is running in a regular window we can move things on top of that just fine. Even if Chrome window is covering entire desktop there is no "ghosting". Windows move fine without leaving the trace. but as soon as we maximize Chrome window we start seeing "ghost" images of windows that used to be on top of Chrome.

Our clients are mix of Wyse terminals, laptops, desktops, Windows, Macs, remote users through Netscaler, local users through WebInterface. No matter which way they access it they all experience the problem. Windows 10 seem not to be affected. but we have rather small population of WIN10 users. 

problem seem to have started happening shortly after we upgraded from Chrome 70 to Chrome 71 but i am not 100% sure. Unfortunately we have to run the latest version of Chrome (which is currently 72)

I have attached a screenshot showing me moving one explorer window on top of maximized Chrome. You can see several "ghost" copies of the one window as it is being moved on top of the Chrome.

we use Citrix UPM and do not have any complicated and unusual graphic policies.


any suggestion would be greatly appreciated.



Link to comment

15 answers to this question

Recommended Posts

So i have accidentally solved this problem for us. I have disabled chrome flag named Viz Display  Compositor (OOP-D).

We have been running it like that since yesterday and seen no issues.


I have also created new shortcut for Chrome for users and placed it on their desktop  

shortcut has modified target as : 
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-features=VizDisplayCompositor 


i hope this will help someone.


Link to comment

Update: rolling back to VDA 7.15 cu1 has fixed the problem. I have not tried to back rev Chrome yet.


I have encountered the same behavior since we started testing CU3.


I was able to eliminate part of the problem by setting the following Citrix policies:

Allow visually lossless compression: Enabled

View Window contents while dragging: Disabled


I found this in the following article: https://support.citrix.com/article/CTX224826


I still get refresh problem when hovering over or right clicking on icons in the taskbar and a strange flash effect on Chrome's top window bar.


We are running 7.15 LTSR cu3 VDA with PVS 7.15.9 on Windows 2008R2 in a published desktop scenario. We are running Chrome 72.


Any other suggestions are appreciated

Link to comment

Thank you for your response and your suggestions.

unfortunately for us we have had both of those settings already configured as that article suggests. 

I downgraded to CU2 but that did not help. Windows is still slow when refreshing over maximized Chrome.

i'll try installing CU1 and see if that works. 




Link to comment

yeah, for some reason unbeknownst to me Flags cannot be managed through GPO. They can be either set by users or managed through preference which sounded complicated and not Citrix friendly.

i opted for deploying Modified Shortcuts (one in desktop and one in Start Menu) and it has worked without any visible impact for two days now. We had few issues with users who created their own shortcuts but we worked it out.  

we are running chrome 72.0.3626.96 on Win7 VDA 7.15CU3.


Link to comment

I have the exact same issue here, it popped up over our last maintenance weekend when a bunch of patches were installed, including Chrome.   Owing to the Christmas holiday period and end of year processing, we skipped the routine patching weekend in December so there were quite a few patches missing.   We are running 7.15CU1 anyway, so rolling back to that isn't going to solve the issue for others I suspect.


I can confirm that so far the only fix I have found is to roll Chrome back to an older version.   Since I had a copy of it kicking around, I've rolled back to v65 and have some users testing it at the moment.    I think the issue came in at the same time that the Chrome UI changed to the new squarer tabs with curvy corners, instead of the ones with angled corners - version 70 or 71 I think it was.   Unfortunately for us, we use Chrome as part of a core business application that is called separately, so passing it parameters at startup is more difficult that just changing a shortcut on the user's desktops.


I've tried installing 32 and 64 bit versions of both consumer Chrome and Enterprise Chrome, latest versions, with no success.  So far, the only fix is to roll back the Chrome version - spent hours on it yesterday afternoon and last night.   Sounds like I will have to investigate the flags thing further, until and unless Citrix/Google come up with something to sort it.

Link to comment
On 11/02/2019 at 2:40 PM, admins Yvelin said:



Same Issue


We are running 7.15 LTSR cu3 VDA with MCS on Windows 2008R2 in a published desktop scenario. We are running Chrome Version 71.0.3578.98.


I have open a case to support



Hi yvelin01,


Can I ask how your case is progressing with Citrix support?   We have the same issue here and have temporarily rolled back the Chrome version on some test machines, but Security from head office is not going to like that one little bit...    Would be great if there was a fix being prepared, that I can hold them back with.


Maintenance weekend is also fast approaching for us, would be great to get something lined up to go in that.


Link to comment

An update for anyone following this:   I raised my own case with Citrix support.   They were able to reproduce the issue on both Windows 7 and Server 2008R2, but (correctly, I think) determined that it wasn't Citrix at fault since the same issue appears if you RDP onto the machines and bypass all the Citrix side of it.   They also tested a machine with no VDA software installed at all, and the issue still remained.   So definitely looks like a Chrome issue here.


I had a brief play with the beta version of Chrome 73, which seems from my initial testing worked OK.   That is likely to come out in the next few weeks so hopefully it will be fully resolved then.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...