Jump to content
Updated Privacy Statement
  • 0

An error has occurred while connecting. Check your server address and data connection. Error Code 548


Vincent Lewin1709156903

Question

Hi All,

 

I have started recieving this error on android devices. A few weeks ago I successfully added my netscaler to workspace and worked fine. Today I cannot add it, instead I get this error.

 

If I launch workspace on a device that already has this account on it it logs me in fine and I can launch apps I just cannot add it a fresh to a new device!

 

I dont seem to be able to find much information on this error 548 online.

 

Netscaler is version 11.1 51.21.nc VPX200

Storefront is LTSR 7.6 - 3.0.1.56

Android Workspace 18.12.0.0 (1812)

 

Thanks for any help you guys can offer

 

Vince

Workspace_error.thumb.png.4ea79dd6ae42b3c8cea714bf7737a914.png

 

Citrix Workspace for Android feedback

Link to comment

5 answers to this question

Recommended Posts

  • 0

hey,

 

probably way too late but you get this error when in Netscaler your "Android" session profile no longer gives authorization to the internal resources. In the example below for instance I have my default global settings set to "Deny" as default action and then I have created the specific "Receiver" session profile (for incoming connections form Android & Co) to overrule that with a default action of "Allow" for those specfic type of connections that match my "Receiver" policy:

image.thumb.png.fb192da10a4b9653370ee1bb4dfbe8bd.png

alternatively you can set deny but only give access to specific resources.

 

If you want a quick test to validate if it's that setting just temporary set this option to allow in your netscaler global settings:

 

image.thumb.png.372b5cd4c581c99434f6f4c04d5cacbc.png

 

IMPORTANT NOTE: setting the option to default (="deny") will immediately trigger the 548 error but only for new Android receiver/workspace profiles that are being configured from scratch (on the android device). If you simply use an existing profile and click a desktop it will not check this setting at all and still launch because the specific Netscaler subdir (/AGServices/discover) this option gives access to only happens during the 1-time initial setup of the android profile. Past that point you don't check or trigger this option anymore.

 

However, once you have created a new android profile and thus immediately triggered the 548 error this error state remains cached on the netscaler until you reboot the netscaler. Simply setting the option again to "Allow" alone is not sufficient! This can lead to wrong/confusing conclusions if not known up front...

 

So in order to test by toggling this option to "deny" or "allow" make sure you do the following 2 actions between each toggle test: Reboot Netscaler and delete your android receiver/workspace profile

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...