Jump to content
Welcome to our new Citrix community!
  • 0

Strange keyboard issues on Workspace for Chrome 1901, 1811.3


Matt Ware

Question

I have a user experiencing weird keyboard issues with the two latest versions of Citrix Workspace.

 

The keyboard stops working in session, mouse continues to work. Both the internal and external keyboards stop working when this happens.

 

Taking the Citrix session out of fullscreen and putting it back into fullscreen fixes the issue.

 

I've tried submitting a support case, but Citrix support does not seem to understand anything about how their Chrome app works. Support agents don't understand the issue and don't even read the full support case. So here I am.

Link to comment

14 answers to this question

Recommended Posts

I have the same exact problem.

VDI's are Windows 10 1809

VDA is 1811

Using Chromebooks with the Workspace app to connect to the VDI's

Using a Diamond Mutlimedia docking station with dual monitors.

The users running dual monitors have this issue were they have to move to windowed screen and then go back to full screen with both monitors to clear the issue.

The issue usually affects 1 program not all of them which is really weird.

Single monitor users do not seem to suffer from this.

Link to comment
30 minutes ago, Russell Timberman said:

I have the same exact problem.

VDI's are Windows 10 1809

VDA is 1811

Using Chromebooks with the Workspace app to connect to the VDI's

Using a Diamond Mutlimedia docking station with dual monitors.

The users running dual monitors have this issue were they have to move to windowed screen and then go back to full screen with both monitors to clear the issue.

The issue usually affects 1 program not all of them which is really weird.

Single monitor users do not seem to suffer from this.

 

 

I was able to resolve it  by rolling the Chrome device back to V70, I found a couple reports of similar issues from people with ChromeOS V71. The issue was resolved for my user at least.

 

Side question: Which Diamond Multimedia dock do you deploy? Does it work with dual monitors over a single USB-C connection? I've struggled to find a dock that would provide dual monitors to Chromebook users over a single USB-C connection. I found one device that does it from Cable Matters, but it doesn't work reliably. 

 

Thanks!

Link to comment

The model # is DS6950 and it uses a single USB-C connection to get dual DP or HDMI connections.

It's plug and play. 

There is no power supplied to the chrome book and you will have to use the power adapter from the chromebook to keep it charged.

I thought that might be the problem and swapped out with another docking station but it did not help.

I will try the roll back on the OS to see if that clears up the problem.

 

Thanks for the tip!

Link to comment

Hi,

 

Can you please try the EAR / tech preview that has the bug fix for keyboard not working on secondary monitor : https://chrome.google.com/webstore/detail/citrix-workspace-app-tech/lbfgjakkeeccemhonnolnmglmfmccaag?hl=en&authuser=6 

 

Please share the feedback.

 

Note : Following app id has to be whitelisted in the storefront to use the EAR:

 

App id: lbfgjakkeeccemhonnolnmglmfmccaag

Link for the document: http://docs.citrix.com/en-us/receiver/chrome/current-release/deploy.html

 

STEPS:

1)      On the StoreFront server, use a text editor to open the web.config file for the Receiver for Web site, which is typically located in the C:\inetpub\wwwroot\Citrix\storenameWeb directory, where storename is the name specified for the store when it was created.

2)      Locate the following element in the file.

<html5 ... chromeAppOrigins="chrome-extension://haiffjcadagjlijoggckpgfnoeiflnem" ... />

3)      Change the value of the chromeAppOrigins attribute to

 

chrome-extension://haiffjcadagjlijoggckpgfnoeiflnem|chrome-extension://lbfgjakkeeccemhonnolnmglmfmccaag

 

 

Regards

Shruthi U

Link to comment

Thanks for the update.

Has anyone been able to use the .cr files from their storefront to auto configure the app?

I have tried jumping through hoops to get this working so we can remove and re-deploy citrix workspace but nothing works.

Removing the old app and installing the latest one blows out the configuration which all we need is  2 urls (internal and external).

The documentation and how to configure the workspace app in Google is really lacking.. I guess only 3 people in the world work on this.

In the deployment side there are like 4 different options for configuration files but almost no documentation unless in passing on how to setup these files as the .cr file I generate from my storefront does nothing and when dragging and dropping into the extension of chrome just errors out saying information is missing...

Way to go Citrix.

Link to comment

Hi,

 

You can refer to this link https://www.citrix.com/blogs/2016/08/17/receiver-for-chrome-configuration-options/ to understand the steps to push policy via Google Admin console and other ways to configure. 

 

You can use the utility to generate the policy file easily. Refer to https://www.citrix.com/blogs/2017/11/06/citrix-receiver-for-chrome-and-html5-configuration-simplified/ for more info.

 

policy_with_beacons.txt - Sample policy file with internal/external urls and with beacons also.

policy_without_beacons.txt - Sample policy file with just internal/external urls

 

You may refer to them and let me know if you need more help.

Link to comment
13 hours ago, Russell Timberman said:

Any idea how to add a store to that?
All I get is the availability to add one store.. we need 2 at our company.

Internal and external. 
This is the part I was having the problems with a none of the documentation says anything about adding a second storefront

Hi,

 

I understand that you have 2 urls one is internal or store url and the other is external or gateway url. If my understanding is correct then probably can you replace internal url and external url in the sample below with the values you have ?

{
    "settings": {
        "Value": {
            "settings_version": "1.0",            
            "store_settings": {
                "rf_web": {
                    "url": "<internal url>"
                },
                "gateways": [
                    {
                        "url": "<external url",
                        "is_default": true
                    }
                ]
            }
        }
    }
}

Also, do you guys use multiple internal urls (store urls)?

Link to comment

We do not use multiple stores.

The setup (that was in place before I was hired) has the external URL going to our netscaller.

Internally it goes directly to the storefronts.

 

When I did this manually I was able to add both URLs and then the user could choose which url to use depending on their location.

For the life of me I can't figure out how to do that with the policy.

 

What we have done is put the external name into our local dns so it will go to our internal setup when they are locally in our offices.

Once outside our network it will just go to the netscaller.

 

This seems to work but I will test more and verify.

Link to comment

You got to update the beacons also to do that. You may please replace the internal and external urls as highlighted below in bold and then push the policy.

Sample below :


{
    "settings": {
        "Value": {
            "settings_version": "1.0",            
            "store_settings": {
                "rf_web": {
                    "url": "internal url"
                },
                "gateways": [
                    {
                        "url": "external url",
                        "is_default": true
                    }
                ],
                "beacons": {
                    "internal": [
                        {
                            "url": "accessible internal url "
                        }
                    ],
                    "external": [
                        {
                            "url": "accessible external url"
                        }
                    ]
                }
            }
        }
    }
}

Link to comment

I can also confirm this clears up the dual monitor issue.

On another note is there anywhere were it is documented on how to manage this extension from AD GPO?
No problems through google enterprise but our company wants to go AD connected devices and I see nothing out there for how to configure the extension with GPO's

 

Thanks!

Link to comment
2 hours ago, Russell Timberman said:

I can also confirm this clears up the dual monitor issue.

On another note is there anywhere were it is documented on how to manage this extension from AD GPO?
No problems through google enterprise but our company wants to go AD connected devices and I see nothing out there for how to configure the extension with GPO's

 

Thanks!

 

I'm unsure about managing the actual configuration of Workspace app, but you should be able to manage the devices from active directory. You'll still have to pay for enterprise enrollment licenses though, so it may not be worth it if you are working fine on Google Admin.
 

Check this out: https://support.google.com/chrome/a/answer/7497916?hl=en

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...