Jump to content
  • 1

macOS: prevent workspace/receiver from starting at login/boot


Casey Boettcher

Question

5 answers to this question

Recommended Posts

  • 1

I could prevent receiver from starting at login/boot:
I had success by deleting the following 4 files distributed in LaunchAgents- and LaunchDaemons- folder of the general Library folder (not the user-dedicated ~/Library -folder!). I have no problems reconnecting to the citrix-system of my employer and to use it.
Of course it is a good idea to make a backup of these files or to store them into an archive before deleting them.
and of course I am not able to garante that my work-around is suitable to all kinds of possible Citrix-Receiver-application. Furthermore I have no idea, if it is also suitable to the new Citrix-Workspace.

 

Here what to delete where:

Quote

/Library/LaunchAgents
    com.citrix.AuthManager_Mac.plist
    com.citrix.ReceiverHelper.plist
    com.citrix.ServiceRecords.plist
/Library/LaunchDaemons/
    com.citrix.ctxusbd.plist  

 
    
Receiver 12.9.1
macOS:  10.13.6

Edited by u2qofboz6lrxgk5@jetable.org
state out Here what to delete where
  • Like 1
Link to comment
  • 0
On 2/8/2019 at 3:53 PM, Ch Di said:

I had success by deleting the following 4 files distributed in LaunchAgents- and LaunchDaemons- folder of the general Library folder (not the user-dedicated ~/Library -folder!).

 

The above worked for me.

ReceiverHelper and ServiceRecords launch agents both have a boolean RunAtLoad parameter, which I tried setting to false, as well as a Disabled parameter, but changing these values didn't seem to work. However, I only tried logging out and back in, and did not try restarting after making the launch agent plist file changes.

Link to comment
  • 0

This is really unacceptable. Not ever user is going to sign into Citrix on a constant basis... and presenting the sign in window just increases their frustration.

 

I checked through all the preferences in Citrix Workspace, and then resorted to googling until I found this thread.

 

With the latest version (22.08.1) it seems that simply removing com.citrix.ReceiverHelper.plist is enough to prevent the app from auto-launching. And is a much more acceptable solution than the one provided by Arpit Vijayvargiya above. I tried changing the loadatlogin key in the plist from true to false, without success. So I'm not pushing a script to all my customer machines to delete that plist file to prevent calls from users.

 

The next option is to simply stop using Citrix sooner than expected, as we're already phasing it out in favor of VDI and other tools.

Link to comment
  • 0

Heey

Just wanted to do the same. It's the year 2022 and I'm running Version: 22.08.1.43 (2208) ?

In /Library/LaunchAgents, I had to delete com.citrix.ReceiverHelper.plist and for com.citrix.ServiceRecords.plist and com.citrix.safariadapter.plist open the files and set the value "RunAtLoad" to "false".
Can't really make sense of it but it worked. I didn't touch the files in /Library/LaunchDaemons/.

Hope this helps and I wish you a wonderful day. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...