Jump to content
Welcome to our new Citrix community!
  • 0

Ralf Grashoff

Question

Hi,

we´ve got 6x DL3690G9 with Xenserver 7.1CU1 running... since one year all is fine. The VMs are stored on local ssd-storage.

Now i´ve made a rolling pool upgrade from 7.1CU1 to 7.1CU2... and now i´ve got much trouble with the performance (freezing screens mit Xenapp 7.15.3000)... is there an easy way back to 7.1CU1?

Or do i have to do a clean install?

Or does anybody know about problems with the performance?

 

Best regards,

Ralf

Link to comment

Recommended Posts

I have the same Problem BSOD (win32kbase.sys, system service exception) on some xenapp-servers in my Environment.

I have a pool of two hosts with XenServer 7.1 CU2 and 20 terminalservers (VDA 7.15.3000).

It's only Happening since I installed new xenapp-server wirh Windows Server 2016.

I didn't had this before with 2012 R2.

 

There is no solution till now ?

Link to comment

I don't know what the changes werer from 7.1.0.1323 to 7.1.0.1227, but I don't think it was major, probably just security fixes.

Are you streaming your terminal servers? If so how does Windows VM's compare to your streamed ones ? Or how does a 

linux VM compare to a windows VM ? 

 

It might not be XenServer, but some other part of your infrastructure.

 

--Alan--

 

Link to comment

Hi there,

this week was horrible... we´ve had strange problems with our Terminalservers (MS Server 2016).
1. Users reported that the taskbar will freeze daily more than one time... partially every 30-60 minutes - since monday. The weeks before where gone without problems. With the workaround (taskmanager, restart windows explorer) they could help themselves - but it should not be...
2. From lunch time till end of working day some Servers (not all!) get a BSOD (win32kbase.sys, system service exception).
We´ve made no changes/installations/patches/configurations last weekend. Nevertheless i´ve tested many things with the master image incl. new Rollouts etc... Unsuccessful.
Yesterday evening i´ve shut down and restart the Xenhosts. Now the problems of the week where gone. Without changes on the VMs!

Was it a Xentools/Driver Problem? I´ve seen a new driver package:

http://downloadns.citrix.com.edgesuite.net/14266/managementagentx86.msi  7.1.0.1327    5607424    x86    0
http://downloadns.citrix.com.edgesuite.net/14264/managementagentx64.msi  7.1.0.1327    5640192    x64    0

I´ve compared this new 7.1.0.1327 with the last 7.1.0.1323... the drivers seems to be the same (because of the date/time), only the install-files changed.
Does anyone know more?

Link to comment

After time consuming investigation I found the reason for the issues we saw:

For specific tasks we have connected a SMB SR on the updated XS 7.1 CU2 host.
If I work with the disk images I create  sometimes manual security copies of the existing VHD files.
As soon as the copy  ends with ".vhd" (like backup1.vhd) it is not possible to scan the SR anymore. And if I try to start the VM with the attached original vhd from that SR it does not work as expected.
As soon as I rename the backup to backup1.vhd.bak, so that it does not ends with ".vhd" all works again.

I cannot remember that I had this behavior with XS 7.1 CU1, but it might be copies had a different naming...

Kind regards

Jens  

Link to comment

Hi Ralf,

 

I'm not 100% sure, but I think I did uninstall en re-install. Didn't trust the auto update in the first place.

But I will do again.

 

Latest can be found in https://pvupdates.vmd.citrix.com/updates.latest.tsv

Quote

http://downloadns.citrix.com.edgesuite.net/14262/managementagentx86.msi           7.1.0.1323          5611520   x86       0

http://downloadns.citrix.com.edgesuite.net/14263/managementagentx64.msi           7.1.0.1323          5640192   x64       0

 

 

Thanks.

Link to comment

Hi,

 

Same freezes with 7.1 CU2 and updated tools 7.1.1323

I tried to revert to backup of Golden Image with tools 7.1.1229

It will do an automatic update to 7.1.1323

 

That won't help me.

Installed managementagentx64.msi from the CU1 iso. This is 7.1.1044

with the Disallow automatic management agent updates.

 

Anyone knows where can I download other versions?

 

Mark

Link to comment

Hi,

no, i´ve not moved the vm. Actually it´s not possible.

But...: i´ve new experiences with my golden image: with installed tools i´ve tried to install MS-Patches via WSUS. After installallation and reboot i spend hours with "waitung for configuration"; Logon was not possible. The performance Graphs shows one CPU by nearly 100%... over 6 hours. The i pressed "Shut Down". I revert to the last snapshot - then i´ve uninstalled the tools. Next Step: WSUS Patch Installation - this time it works!

Now i took a new snapshot, the next step is installation of the "brandnew" Tools. I´m curious...

 

Ralf

Link to comment

Now our VMs are running with the latest drivers. It seems to be that the xenvif-driver 8.2.1.175 is working.

But i´m not happy with one host (from 6) with 2 running VMs (Windows Server 2016) - the system-process in Taskmanager runs very often very high...

Top (first 2):

 1140 root      20   0   37532   5376   4164 S   6.3  0.1  10:06.94 tapdisk
32541 root      20   0   37532   5376   4164 S   4.0  0.1  11:51.90 tapdisk
Then a lot of vifs....

 

Xentop:

xentop - 11:28:47   Xen 4.7.6-1.26
3 domains: 3 running, 0 blocked, 0 paused, 0 crashed, 0 dying, 0 shutdown
Mem: 268306768k total, 151526076k used, 116780692k free    CPUs: 24 @ 2397MHz
      NAME  STATE   CPU(sec) CPU(%)     MEM(k) MEM(%)  MAXMEM(k) MAXMEM(%) VCPUS NETS NETTX(k) NETRX(k) VBDS   VBD_OO   VBD_RD   VBD_WR  VBD_RSECT  VBD_WSECT SSID
  Domain-0 -----r      52795   36.4    8388608    3.1    8388608       3.1    16    0        0        0    0        0        0        0          0          0    0
     TS003 -----r     113473  972.2   67108876   25.0   67109888      25.0    16    0        0        0    2        0   304379  1369939   12967318   50434372    0
     TS009 -----r     128071  801.7   67108876   25.0   67109888      25.0    16    0        0        0    2        0   300783  2251095   13001471  117328281    0
 

Any ideas?

 

Ralf

 

Link to comment

Ralf,

New tools should work fine, and I'm not even sure there's much of a difference between CU1 and CU2. We have not updated ours on any VMs that made the transition and all looks fine so far.

Keeping the BIOS/firmware up to date is important and should be done uniformly on servers, as well, as sometimes a change will affect the CPU feature set.

 

-=Tobias

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...