Jump to content
Welcome to our new Citrix community!
  • 0

Error when run as seamless app...not from console session

Nelson Kaeppel


I am trying to run a published seamless app and I get this application error:




But when I run the same app from a desktop console session, it runs fine.  The error is definitely generated from the application and not Citrix (or the Citrix client) - but yet I cannot help but think that running it as a published app is part of the problem - since it runs fine from the desktop via an RDP session.


I have tried:

  • Running with and without local admin rights - same problem
  • One monitor and two monitors - same error
  • WorkSpace App vs. Citrix Receiver - same error
  • Rebooting - same error


Whats odd is that we originally deployed this on a test Windows 2016 server in a test site and it works fine.  Now when we deploy it on our production site, running Windows 2016 - it gives the error.  The servers are for the most part identical.  Same patches, .Net version, version of Citrix Virtual Apps...just in different sites.


Anyone have suggestions how I might begin to troubleshoot this?



Link to comment

2 answers to this question

Recommended Posts

  • 1

Stupid rookie mistake.  I set a working directory in test for the published app, just by luck and not knowing it was required.  When I set production, I never bothered to set a working directory, as most applications don't require it.


Well, apparently this application does...once I set the working directory, it worked like a champ.


  • Like 2
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...