Jump to content
Welcome to our new Citrix community!
  • 2

Connections to VDA on port 2598 fails during SSL handshake phasing


Question

Hi,

 

I have created a catalog for Windows 10 VDI hosted on Azure (DDC and SF on premise). When I try to connect to the VDA with Citrix Receiver app it fails with unknown error 0 or unknown error 1110. I have realised that the problem occurs when my computer tries to connect to the VDA on port 2598, the defautl option for Citrix Receiver app; I have disabled the session reliability on the Netscaler config defined in StoreFront and tried to connect via the NetScaler and it worked, because here we're using port 1494 instead of 2598.

 

If I connect to the VDA and look for the logs I can find the following one related to the connections on port 2598:

 

"The Citrix ICA Transport Driver connection from xxx.xxx.xxx.xxx:63634 to port 2598 received an invalid packet during its SSL handshake phase."

 

Although session reliability can be only disabled if you connect to the VDAs via Netscaler I cannot "fix" or look for a solution if my users use Citrix Receiver App.

 

I have tried the following solution with no luck:

 

https://support.citrix.com/article/CTX232685

 

Any help please?

 

DDC: 7.18

SF: 3.16

VDA: 7.18

Citrix Receiver: 4.12

Firewall disabled on VDA

 

Regards,

 

Jorge

Link to comment

5 answers to this question

Recommended Posts

  • 0

UPDATED INFO:

 

I have been testing some connection settings I explain:

 

  1. Connection with Citrix Receiver App 4.12 directly: it doesn't connect to VDA with session reliability (port 2598)
  2. Connection with Citrix Receiver App 4.12 directly: it doesn't connect to VDA without session relilability (port 1494); i have disabled session reliability via Citrix Studio policy.
  3. Connection with NetScaler via HTML5: it connects to VDA correctly (port 2598 (Session Reliability is enabled on the NetScaler GW))
  4. Connection with NetScaler via HTML5: it connects to VDA correctly (port 1494 (Session Reliability is disabled on the NetScaler GW)) 
  5. Connection with NetScaler via Citrix Receiver: it connects to VDA correctly (port 2598 (Session Reliability is enabled on the NetScaler GW))
  6. Connection with NetScaler via Citrix Receiver: it connects to VDA correctly (port 1494 (Session Reliability is disabled on the NetScaler GW))

As you can see I only can't connect to VDA if I use the Citrix Receiver App directly. I have reinstalled it but the issue persists.

 

Any clue?

 

Regards,

 

Link to comment
  • 0

Hi

 

we have the exactly same issue with the invalid packages over port 2598. But in our environment, the users fail to connect to the XenApp 7 Published Apps only if the following condition is true:

  • Connect via DirectAccess only via internal network (internal Netscaler Gateway) and on Citrix Receiver 4.6 and higher

The Issue began on wednesday,  november 28th - maybe a Windows Update Issue?

Strange kind is, the Published Desktops (VDI's) are running well, as well as the Connection via Development Environment of the DirectAccess infrastructure is doing or if you downgrade to Receiver 4.5.

 

Do you have a solution?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...