Jump to content
Welcome to our new Citrix community!
  • 1

WaitForPrinterCreation not Working


Martin Hanspeter

Question

Hello,

 

i´ve a fresh installed XenDesktop 7.18 Farm where we´ve to publish some applications for our external partner.

 

In the settings of the published applications we´ve enabled the option "waitforprintercreation" via the powershell, but it doesn´t works. The application start and the printers were redirected  with some delay. The problem is that this legacy application doesn´t recognize the printers which are installed after the launch of the application.

 

Thanks in advanced for your help

 

Martin

 

WaitforPrinterCreation.JPG

Link to comment

6 answers to this question

Recommended Posts

  • 1

Thanks. According to the documentation, that's only supposed to work for published desktops, but I found it worked for my published application. So, I ran the powershell script:

Set-BrokerApplication "AppName" WaitForPrinterCreation:1

Then I also set the policy "Wait for printers to be created (server desktop)" to enabled.

When these two things were completed, printers loaded in the background before my published app was presented to the end user for interaction. 

Hope this helps someone else.

  • Like 1
Link to comment
  • 0

Anyone get this resolved? We are seeing the same thing with 7 1912 LTSR.

I've run the powershell command to set the WaitForPrinterCreation flag to true. I've confirmed it's set to true for the published app. I can demonstrate that the app still launches before the printers are created. 

Link to comment
  • 0

Using the PowerShell command on the apps worked for an issue I hit. I just upgraded VDAs from 1912CU7/8 to 2203CU4, delivery controllers are still 1912, so I'm not sure if that's contributing...

 

When the VDAs were 1912, it appeared that the "Wait for printers to be created (server desktop)" policy worked on stand-alone apps (not launched through Citrix Desktop) because I previously enabled the policy to force the application to wait and it worked, but after upgrading the VDAs to 2203CU4 the apps would not wait for printer creation before launching. Running the PowerShell command (Set-BrokerApplication "app_name" -WaitForPrinterCreation:1) from the delivery controller corrected the issue. I guess that policy wasn't intended to work with stand-alone virtual apps and that got fixed in a newer release? *shrug*

 

Anyway, say you have all of your "legacy" applications in an application group and you want to update them all at once:
 

$brGroup = Get-BrokerApplicationGroup "app-group-name"
$brGroupApps = Get-BrokerApplication | Where {$_.AssociatedApplicationGroupUUIDs -match $brGroup.UUID}

ForEach($app in $brGroupApps){
	Set-BrokerApplication $app.Name -WaitForPrinterCreation:1
}

# Might need to wait 5-10 seconds before the change appears, but this will reflect the change
Get-BrokerApplication | Where {$_.AssociatedApplicationGroupUUIDs -match $brGroup.UUID} | Select Name,WaitForPrinterCreation

 

Edited by David Joye
Grammar, clarity.
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...