Jump to content
Welcome to our new Citrix community!
  • 1

Bastian Frohnhoefer

Question

Hi everybody,

 

since we upgraded to 1808 (from 7.17) the graphic quality has changed and we cant figure out why.

We have 3 Scenarios: Terminal Server, Remote Desktops with Physical Machines and Virtual Desktops on a Tesla M60.

 

On the Terminal Server we normally use the HD preset from Citrix which worked fine before 1808.

So the main settings are quality preset "high" and enable videocodec compression for the whole screen. (as my interface is german i hope the naming is correct)

Since 1808 the Fonts are fuzzy for about 1 second before they get clear.

We first tried to change the quality to "build to lossless" but this doesn't really change the behavior.

If we set "always lossless" the fonts are ok but the Server performance does decrease.

After several tries we found out if we disable "Use Videocodec for compression" it seems to be much better but still not the same as before.

Also we disabled progressive display as since 1808 it is enabled by default regarding to the documentation,

but as expected this doesn't change anything.

 

On Remote Desktops and Virtual Desktops with Nvidia VGPU we normally use the following setting:

Always lossless and use Videocodec for Compression for the whole Sceen.

This setting still is fine with 1808 and Autodesk / Adobe Products, but at this setting Videos which cant be redirected aren´t Smooth.

So we tried to switch to "Build to lossless" but the the fuzzy fonts appears also. At the same time videos play smooth now.

 

The Clients we are using to connect are mainly Dell Wyse Thin OS Clients 3040 and 5060 from the internal Network.

 

So maybe this are to different problems but i want to show you the whole Setup.

 

We know that the HDX codec has been changed from JPEG to H.264/5 and that progressive display has been enabled by default but both of it should not affect our Internal connection.

Do you have any hints or maybe working Presets for this scenarios which we can try?

 

regards

Bastian

 

 

Link to comment

16 answers to this question

Recommended Posts

  • 0

Hello Bastian,

 

Check if Legacy graphics mode has been enabled.

Visual quality should be set to High but it will require more bandwidth. Check the same on a Fat client and compare the performance on a Fat and a Thin client.

Set Display memory limit to maximum: 4,194,303

 

Try "Use video codec when preferred" 

 

-Deepanshu 

 

Link to comment
  • 0

Relevant changes to graphics, since 7.18 are described here: https://www.citrix.com/blogs/2018/06/05/hdx-graphics-goodies-in-7-18/

 

For Virtual Apps (TS) the recommendation is to use default graphics policies. In this case we would use the best codec based on screen content, such as text, images, or video. We only recommend full screen video codec for 3D/design applications when using GPUs. 

 

For VDIs with NVIDIA GPUs we recommend enabling the "Optimize for 3D Workloads policy" if the use-case is mainly intensive graphics apps that require hardware acceleration, like Autodesk products. This will result in full screen video codec. It will also leverage the GPU for H.264 hardware encoding (NVENC) assuming the GPU/drivers support it. For a mixed use case of standard office productivity apps we would recommend default settings.

 

Always lossless is for very specific use cases where pixel perfect image quality is desired (medical imaging for ex.), and this comes at the expense of significant bandwidth consumption and reduced frame rates. Enabling both lossless and video codecs results in a conflict where the video codec is disabled completely. Build to lossless with video codec enabled would result in H.264 build to lossless mode as explained in the blog post linked above. 

 

The new progressive display mode in 7.18+ will be activated when network latency is above 200ms or bandwidth drops below 2Mbps. These thresholds can be configured or disabled altogether as documented here: https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/graphics/thinwire.html#progressive 

 

 

Link to comment
  • 0

Thanks Roberto,

 

yes i know this article but it didn't help us so far.

As mentioned we are using the HD default set for the Terminal Server Virtual Desktop.

On the Nvidia GPU for sure we are using Optimize for 3D Workload but we still need Always lossless which we shouldn´t as the article clearly shows.

And the new progressive Display has been disabled by the registry key just to be sure.

I changed the display memory limit and waiting for the reports from the user.

 

regards

Link to comment
  • 0
8 hours ago, Bastian Frohnhoefer said:

Thanks Roberto,

 

yes i know this article but it didn't help us so far.

As mentioned we are using the HD default set for the Terminal Server Virtual Desktop.

On the Nvidia GPU for sure we are using Optimize for 3D Workload but we still need Always lossless which we shouldn´t as the article clearly shows.

And the new progressive Display has been disabled by the registry key just to be sure.

I changed the display memory limit and waiting for the reports from the user.

 

regards

 

Can you explain what you mean when you say you "need" always lossless. Maybe share some details around the use case in terms of the apps and desired user experience. You mention 3 different deployment modes, XenApp/RDS, VDI, RemotePC, and Im no clear on what issues you have where. 

Link to comment
  • 0

Sure, thanks for asking.

 

XenDesktop on Server2016: Fuzzy Text for a second after switch to a different Window or sroll through Outlook. Target Quality: "High"

 

RemotePC and VDI are using the same presets.

On the VDI we are mainly running Adobe Creative Cloud (Photoshop, InDesign) beside the normal Office Apps. Build to lossless seems work here, but then the fuzzy Text is appearing here also.

On the Remote Desktop we are using Autodesk 3DsMax and AutoCAD, this two programs have to much artefacts regarding to our Designer if we not select "always lossless"

The fuzzy Text is appearing here also.

 

So I think this are two different things.

The fuzzy text on all Systems since 1808, and the needed always lossless which should be the case if i got this correctly. If videos would play normal with always lossless we wont care about this setting.

But at the moment the main problem is the fuzzy text.

If the user will report that the video memory policy wont change anything and you don't have any other suggestions I think the best way is to downgrade the VDA only and check if something is changing.

If not maybe Citrix is not the one to blame.

 

The customer is upgrading a lot of stuff at the same time so at least there could be an other cause.

For example the got a new Network Storage with HA support and also a new Phone System with IP Phones.

The also got new Switches but this was  some month ago so this shouldn´t be the case.

Also on some places, but not all affected places the Thin Client is connected behind the IP Phone cause of missing Network Ports.

 

BY the way the fuzzy text is sometimes more sometimes less. We also checked on some Clients with HDX Monitor but HDX Monitor always detects LAN Network with 0ms latency.

Link to comment
  • 0

Some things to consider:

  1. With default graphics policy settings we use selective encoding and anything we identify as text would be rendered using the lossless codec. There are exceptions to this in some cases like when you are playing a video that happens to show text in certain frames, we would just encode the whole video window with our video codec. 
  2. If you are using the video codec for the entire screen then we dont use lossless text by default. The video codec will adapt image quality based on network conditions and this could result in fuzzy graphics or text. H.264 video codec is adaptive by design and the image quality settings (L/M/H) simply dictate max quality settings.
  3. If you must use video codec for the entire screen but need lossless text, you have the option to enable this via the registry. HKLM\Software\Citrix\Graphics\TextOptimization = 1 (DWORD). This option does come at the expense of CPU util and GPU hardware encoding (would be disabled) so keep that in mind. 
  4. I think the best compromise would be to use the new H.264-based Build-to-lossless in 7.18+. In this case you would get the performance you need for the design apps and maintain lossless quality for still images. Unless you are moving text around (ex. scrolling) you should not be seeing fuzzy text as we only update screen areas when they change.
  5. Video memory is only relevant for the session size meaning max resolution and number of monitors, see CTX201696. This has nothing to do with image quality.
  6. There is a bit of a wildcard when using Wyse ThinOS as they use our Windows client build running in their linux-based platform with their emulators and graphics rendering components. I would recommend testing with a standard Windows endpoint and the latest Citrix Workspace App to rule out any ThinClient specific issues. 

 

Link to comment
  • 0

 

So i was able to test this:

 

On the normal XenDesktop Terminal Server the text seems ok now, after disable "use videocodec for compression"
On the VDI and RemotePC I checked several settings with and without videocodec, visually lossless and the mentioned registry key.
As you said the best result are with Build to lossless and no video compression.
However this still leaves fuzzy text while scrolling as you mentioned above.
The fuzzy text is completely gone if we set always lossless but videos will not be smooth anymore.

 

So for now I can use videos or perfect text, but not both while in the normal XenDesktop session without a GPU I can do this.
For sure I´m not able to use 3dsMax on the XenDesktop but shouldn´t be text work without any issues even while scrolling on a GPU featured desktop?

 

I´m not sure if I can convince the user to accept the scrolling issue while making videos work, so is there a way to use the old compression and not H.264 without downgrading?
And will the text performance increase in future releases?

 

The best way would be to force always lossless but switch to build to lossless while a video is playing but this seems not supported as for now. Also this is not the best for WAN usage.

All of this has been tested with the latest Citrix Workspace client on a Windows 10 PC while on internal Network.

regards

Link to comment
  • 0

Actually, I said the best choice for graphics performance and text quality would be build-to-lossless with H.264, the new mode available with 7.18+ VDAs. If you used BTL with video codec disabled then we would use the JPEG codec for everything while the screen is changing. This is not necessarily bad, but H.264 is much better for video and transient regions when it comes to frame rate (smoothness) and overall performance. 

 

The reason you dont have an issue in TS without the GPU is because you get the best of all worlds when it comes to encoding (assuming default settings are used), jpeg for still images, lossless for text, and H.264 for videos. You can use this mode with a GPU as well, just use default settings and leave the "optimize for 3D" policy disabled. The only disadvantage of doing this would be that we may not detect the 3D apps as video which may or may not be an issue depending on what the app is rendering. 

 

 

 

 

 

Link to comment
  • 0

Hi Roberto,

 

thank you again for the details, got that now.

I was able to proof that I can use the HD settings from our Terminal Server on our VGPU / Remote Desktop and everything is working.

So i did some more testing and as @hotline.kfi@brueckner.com said, the issue seems to track down to the BTL setting.

 

So this are my results:

Default HD setting on Terminal server with Display Quality set to BTL -> Text is fuzzy for a short time

Default HD setting on Terminal server with Display Quality set to high -> everything is fine.

Same two settings tested on VGPU and Remote Desktop with Nvidia 1080 Ti, same results (with BTL Text is fuzzy)

So I tested this again with the settings we used before:

Optimize for 3D Load, Display Quality "BTL", video compression set to default -> fuzzy text for a short time

Optimize for 3D Load, Display Quality "High", video compression set to default -> everything is fine

Optimize for 3D Load, Display Quality "BTL", video compression set to "disabled" -> fuzzy text for a short time

Optimize for 3D Load, Display Quality "High", video compression set to "disabled" -> everything is fine

Optimize for 3D Load, Display Quality "BTL", video compression set to "whole screen"-> fuzzy text for a short time

Optimize for 3D Load, Display Quality "High", video compression set to "whole screen" -> everything is fine

 

All of this has been tested on Citrix Workspace App for Windows and on the Wyse Thin OS Clients, the results for the end user are identical.

Also I noticed that the Thin OS doesn't seem to support the Videocompression, because whatever has been set the Video Codec has been set to "None" regarding to the HDX Monitor, while on the Workspace APP for Windows it shows "for partial screen" if we are using" whole screen" or default settings with the mentioned registry key for text activated.

As this is a new feature this is OK for me, we could enable Videocompression for connections from Home Office as they are using MAC / Windows from home.

 

As this seems not to be a known issue so far should we open a ticket to track this down?

Or maybe somebody can try to reproduce this?

 

regards

Link to comment
  • 0

Hi,

 

i got some feedback from our users:

If the VDI will be locked and then unlocked by the user, the switching between video compression and lossless stops and it is video codec only.

The user can switch 'lossless' on and off with the indicator in the taskbar and after that it is automatically changing again.

 

Beside that, since a few weeks the window positions gets lost after lock/unlock (program windows are moved to default monitor), which sounds crazy to me.

 

Regards

Link to comment
  • 0
On 11/20/2018 at 7:13 PM, Bastian Frohnhoefer said:

Hi Roberto,

 

thank you again for the details, got that now.

I was able to proof that I can use the HD settings from our Terminal Server on our VGPU / Remote Desktop and everything is working.

So i did some more testing and as @hotline.kfi@brueckner.com said, the issue seems to track down to the BTL setting.

 

So this are my results:

Default HD setting on Terminal server with Display Quality set to BTL -> Text is fuzzy for a short time

Default HD setting on Terminal server with Display Quality set to high -> everything is fine.

Same two settings tested on VGPU and Remote Desktop with Nvidia 1080 Ti, same results (with BTL Text is fuzzy)

So I tested this again with the settings we used before:

Optimize for 3D Load, Display Quality "BTL", video compression set to default -> fuzzy text for a short time

Optimize for 3D Load, Display Quality "High", video compression set to default -> everything is fine

Optimize for 3D Load, Display Quality "BTL", video compression set to "disabled" -> fuzzy text for a short time

Optimize for 3D Load, Display Quality "High", video compression set to "disabled" -> everything is fine

Optimize for 3D Load, Display Quality "BTL", video compression set to "whole screen"-> fuzzy text for a short time

Optimize for 3D Load, Display Quality "High", video compression set to "whole screen" -> everything is fine

 

All of this has been tested on Citrix Workspace App for Windows and on the Wyse Thin OS Clients, the results for the end user are identical.

Also I noticed that the Thin OS doesn't seem to support the Videocompression, because whatever has been set the Video Codec has been set to "None" regarding to the HDX Monitor, while on the Workspace APP for Windows it shows "for partial screen" if we are using" whole screen" or default settings with the mentioned registry key for text activated.

As this is a new feature this is OK for me, we could enable Videocompression for connections from Home Office as they are using MAC / Windows from home.

 

As this seems not to be a known issue so far should we open a ticket to track this down?

Or maybe somebody can try to reproduce this?

 

regards

 

Any news about the issue? Have you opened a support ticket?

Link to comment
  • 0

Please use the below settings and try:

 

Hard encoding is ON

Allow visually lossless compression - enabled

Visual quality as always lossless

Use video codec for compression - Entire screen

 

With Nvidia Grid P4 graphics card we were able to achieve sharper grid lines with smooth movement on CAD / Rhino software.

Basically, we tried to achieve the YUV format 4.4.4 and once we could get to YUV 4.4.4 we could see sharp images and smooth movement.

 

For reference read the section under the heading NVIDIA on the following link:

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/graphics-policy-settings.html

 

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...