Jump to content
Welcome to our new Citrix community!
  • 0

Default Printers not mapping in published desktops


AA 2913

Question

Citrix Version - XenApp 7.15 LTSR 

Published Desktops - Windows Server 2008 R2

 

We have published desktops (Windows Server 2008 R2) and when I  print, I do not see it printing to my default network printer. I see Citrix Universal Printer (from DESKTOPNAME in session 25) . I see my network printer, but that is not chosen as my default printer to print.

 

I have enabled the following to test 

1. Auto-create client printers

2. Client printer redirection

3. Default printer

 

We want to map both the default network printer (when at office) and local printer (when user takes the laptop and goes home and connects to Citrix). 

 

Even me enabling the policy has not helped.  Any suggestions.

 

Thanks in advance 

Nano

Link to comment

4 answers to this question

Recommended Posts

We have addressed similar type of issue in 7.15 LTSR CU3 - Intermittently Default Printer might not set correctly in ICA Session where there is no default printer configured in policy, can you check upgrade to CU3 VDA.

 

here are details of the fix.

The default printer might be incorrectly set in a session. The issue occurs when the default printer switches to any other random printer. [LC8999]

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/whats-new/cumulative-update-3/fixed-issues.html

Link to comment

Thanks for the  response. But, in our case we are publishing the desktops and it defaults to Citrix Universal Printer when we logon to the published desktops from a desktop or a laptop. From a thin client it would be point to a different printer. 

 

image.png.c6b01c4f48801191b7a5c3d34e0b91ff.png

 

We have the Enabled Universal Print Server policy and have the following policies set.

 

image.thumb.png.a69b077240ea1e47bec076eca945b3a6.png

 

  • Auto-create generic Universal printer policy
  • Direct connections to print servers
  • Universal print driver usage
  • Universal Print Server enable
  • Universal Print Server print data stream (CGP) port
  • Universal Print Server web service (HTTP/SOAP) port

My issue is that we have other network printers that are available for our session and those network printers are not mapping as default printer and the check mark enabled. So, I am not sure where what is wrong that it is not automatically showing up as that users default printer when he logs onto his published desktop to print. The Group Policy is from Windows Server 2012 R2. Even setting the default printer in Group Policy settings under User Configuration \Preferences \ Control Panel Settings \Printers and if you select the printer and enable "Set this printer as the default printer...."

 

 

 

11 hours ago, Ganesh Raju said:

We have addressed similar type of issue in 7.15 LTSR CU3 - Intermittently Default Printer might not set correctly in ICA Session where there is no default printer configured in policy, can you check upgrade to CU3 VDA.

 

here are details of the fix.

The default printer might be incorrectly set in a session. The issue occurs when the default printer switches to any other random printer. [LC8999]

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/whats-new/cumulative-update-3/fixed-issues.html

 

 

Windows Print.png

Link to comment

All,

 

We are starting to see the same thing now.  The change was to upgrade all systems to 7.15.300 and the VDA updated.  It was not until we upgraded the VDA that the printers stopped mapping for the end user.  We also ensured that the users MAC machine ICA client is 12.1 rather than the newer Workspace.  As the printcfg.exe no longer exist I have no visibility into the printer mappings.  Looking in the event logs of the device he is connected to also does not show any printer mappings as well.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...