Jump to content
Welcome to our new Citrix community!
  • 0

WEM agent - Agent Does Not Launch When a User Logs In


Rotem Sfarad

Question

Hello folks,

 

WEM version 4.7.0.0

agent installed on windows 7, windows 10 - same problem.

 

I'm trying to launch the transformer on PC's.

but the agent not launch automatically when the user logs in to his pc,

if I start the agent manually its works as excepted.

 

already tried to play with the agent time out settings, extra launch delay and etc, but still the agent not launch automatically.

even tried the steps from this article https://support.citrix.com/article/CTX226494 but still not working.

 

any ideas?

Link to comment

3 answers to this question

Recommended Posts

  • 0

I've always had this issue.  Adding this key resolved it when I had WEM on-Prem but now that I've moved to WEM in the cloud it sometimes causes it to try and launch a second time.  You might give it a try though. I believe I originally found this on JG Spiers site.  

 

Launch Agent at Logon
If the agent does not launch on logon, create a registry entry as below:
Name: VUEMUIAgent
Data: C:\Program Files (x86)\Norskale\Norskale Agent Host\VUEMUIAgent.exe
Type: REG_SZ
Location: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

 

 

Link to comment
  • 0

I wanted to update my previous comment  because I found that for me the article that  rsfarad700 referenced was the solution

 

https://support.citrix.com/article/CTX226494

 

1) The Agent would not run when a user logged in

2) The server (Windows 2016) would not register with the WEM service in the Citrix cloud.

 

By simply adding these few lines as a startup script it resolved both of my issues.  The article mentions this being a PVS issue.  I'm using MCS but I can state that it works.  You DO NOT want to add the regekey I mentioned in my previous post if you are using this script.  It will make the agent try and run a second time if you do. 

 

net stop "Norskale Agent Host Service" /y
net start "Norskale Agent Host Service"
net start "Netlogon"
cd "C:\Program Files (x86)\Norskale\Norskale Agent Host\"
AgentCacheUtility.exe -refreshcache

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...