Jump to content
Welcome to our new Citrix community!
  • 5

Receiver on Mac 10.14 ?


harald kjensli

Question

9 answers to this question

Recommended Posts

  • 1

I just encountered this problem and did find a solution.

 

go to Citrix website and download 12.9.1.

also download the auto updater.

open Citrix installer and choose the "Remove Citrix Receiver" option to remove all elements of previous version.

once completed, choose "Install Citrix Receiver" to re-install. It will open as "Citrix Workspace"

Once completed, open the AutoUpdater download and install.

 

Make sure to address the appropriate option under Safari/preferences/website to allow use of Citrix Workspace.

Citrix now works as before.

  • Like 1
Link to comment
  • 1

The terminal command is the correct one. I got notification that this was fixed in the latest version for the mac, unfortunately, it then broke everything else. Can't use Outlook under citrix now at all - it craps out in trying to save, won't let me select new dates from a copied appointment. I'm going back to .9 and just waiting.

 

DISAPPOINTING Citrix.

  • Like 1
Link to comment
  • 0

Similar Issue here. I can connect remotely to my workplace, but the response is painfully slow and the beachball is spinning on every click of the mouse. Any focus on an upgrade?

Correction: My issue was actually with Mojave (10.14) and the new Citrix Workspace (1809). That combination does not work at all for me and triggers the spinning beachball on every switch to a different remote application using alt-tab. Fortunately I had kept my Receiver installation file for version 12.9 and am now back working at acceptable speed. However even after un-installing the Citrix Workspace (1809), it is back in my menu bar after installing the Citrix Receiver (which btw is called Citrix Viewer when running). 

Edited by TomH-H
Not precise in explanation
Link to comment
  • 0

I have had issues with Mojave 10.14 as well.

 

Currently have ticket open with Citrix.

 

Have unsuccessfully tested Workspace App 1809, 1808 & Receiver versions 12.9.1 & 12.8.1.

 

The latest release I have seen working is Receiver 12.7.

 

Netscaler NS11.0: Build 63.16.nc

 

 

Consistent behaviour includes Citrix Viewer application not being responsive.

 

Link to comment
  • 0

I tried the above fix and I didn't work; however, a coworker went into the terminal and applied this fix:

 

run terminal command:   defaults write com.citrix.receiver.nomas PreferMetalRendering -bool NO

 

 this appears to have worked with no more beach balls and using the current version.

5c127965c1aef_ScreenShot2018-12-13at7_04_07AM.thumb.png.883ad025112719ec8f142bc19246936e.png

 

 I'm not certain how many organizations use Apple products but at our university, this is on the rise. Hopefully Citrix will take this into account when making future upgrades by simultaneously upgrading both platforms.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...