Jump to content
Welcome to our new Citrix community!
  • 0

Enabling Network Level Authentication (NLA) on Server-VDA


Wolfgang Germ

Question

Hello,

 

for auditing purposes I got requested to ensure, that Network Level Authentication (NLA) is enabled on VDA.

It is somehow strange, but when I try to enable NLA and set the checkbox on "Allow Connections only from Computers running Remote Desktop with Network Level Authentication" and reopen the dialog, the option is disabled again? (see screenshot)

 

NLA-Dialog.png

 

I wanted to ask, if your VDA have the same behaviour?

Does anybody have an Explanation on this?

 

(VDA: Windows Server 2016, XenApp 7.15 CU2)

 

Thank you

Link to comment

4 answers to this question

Recommended Posts

  • 0

Hello @Panteraa

 

This change should stay there after reopening the dialog unless you have any GPO to disable that or it's disabled on RDP listener:

 

GPO:

 

Computer Configuration\Administrative Templates\Windows

Components\Remote Desktop Services\Remote Desktop Session Host\Security

 

"Require user authentication for remote connections by using Network Level Authentication"

 

Check RDP listener:

 

Since Remote Desktop Session Host Configuration (tsconfig.msc) MMC is no longer there after 2008 R2 so you can connect to 2016's RDP listener remotely from 2008 R2.

 

 Open tsconfig.msc on 2008 R2

 Right click and click on "Connect to another server". Enter 2016 server name.

 Right click on RDP listener > properties.

 In the General tab, Check the Allow connections only from computers running Remote Desktop with Network Level Authentication check box.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...