Jump to content
Welcome to our new Citrix community!
  • 0

Windows 10 disconnect button

Thomas Luther


Hi everybody,


I'm trying to install the workaround Citrix released for the missing disconnect button on Windows 10.

Windows 10 disconnect option is not available to users in XenDesktop sessions

I'm trying to install the included MSI on our x64 Windows 10 Enterprise (v1709) with VDA 7.15 CU2 (also tried 7.17 / 7.18) - unfortunately I get the message "Unable to find required version of VC Runtime Libraries".

Which version is needed in order to install it?


Several versions are installed on the system - see the attached screenshot for details.


Any help appreciated.

Thanks in advance.




VC Runtime.jpg

Link to comment

20 answers to this question

Recommended Posts

  • 0

Unfortunately I get an error:



Add-AppxProvisionedPackage : Unbekannter Fehler
In Zeile:1 Zeichen:1
+ Add-AppxProvisionedPackage -Online -PackagePath x64\Microsoft.VCLibs. ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Add-AppxProvisionedPackage], PSArgumentException
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.AddAppxProvisionedPackageCommand


Link to comment
  • 0

I'm having the same issue, this worked fine on a previous template with windows  1709.

For some reason this will not work anymore, i have tried installing all versions of c++ with no success , i'm doing exactly the same as the previous image , but i cannot get this to work.

i've also tried to remove all the installations of c++ and reinstall them without any success.

Link to comment
  • 0

I got the same error when installing the fix.  The ZIP file provided (containing a batch file and appx file) resolves the issue but you will need to ensure that batch file points to the correct location of the .appx file (also contained in the zip file).  I simply copied the .appx file to c:\ and ran the powershell command as follows:  powershell.exe -ExecutionPolicy Bypass -NoProfile -Command "Add-AppxProvisionedPackage -Online -PackagePath c:\Microsoft.VCLibs.x64.14.00.appx -SkipLicense"


The fix then installed successfully.

Link to comment
  • 0

It seems the installer is dependent on the "Microsoft.VCLibs.140.00_14.0.25426.0_x86__8wekyb3d8bbwe" or "Microsoft.VCLibs.140.00_14.0.25426.0_x64__8wekyb3d8bbwe"

The latest version is Microsoft.VCLibs.140.00 14.0.26706.0 so it seems something is going wrong here.



Just tried and adjusted the msi file with orca editor.

In the table DrLocator, changed the value of VCRuntimeDir and VCRuntimeFolder to Microsoft.VCLibs.140.00_14.0.26706.0_x64__8wekyb3d8bbwe and everything is working again now.

Link to comment
  • 0

Yes, sadly, the problem is that the current MSI expects only Build 25426 of the VC Runtime Libs to be installed on the target VDA. That is why @Gert Staf1709158890 's workaround works. As far as using the zip file with the PowerShell command line, Windows will not allow you to install the VC Runtime Libs appx if another version of the Libs is already installed on the machine (e.g. 26706). That's why @Thomas Luther was getting the PowerShell error. An updated MSI which fixes all of these installation issues should be released soon. Please stay tuned. Our apologies for the inconvenience.



Link to comment
  • 0

Hi Abrahamm, 


There is also another aspect of this product that makes it inconvenient...


The installer places the "Disconnect" button into the Power Options menu only.  In most VDI environments, the shutdown, hibernate and restart options are disabled.  By disabling these options, the "Disconnect" button is also removed, rendering this product useless in this scenario.  


Can you please get the "Disconnect" button added to the "Shutdown or Signout" menu as well as the Power Options menu?  (The specific location for this request is Right-click Start menu > Shutdown or Sign-Out).

It may also be handy to place it under the User Account Settings menu located on the far left of the Start menu.




Link to comment
  • 0

Hello, @Phil Reeves1709156734. Yes, you are right! Adding the Disconnect button to these additional locations makes sense. Our end goal is to have the Disconnect button present in the locations you would normally expect to see it natively in Windows. In this initial version of the MSI, the Disconnect button is only placed in the Power Options popup menu by design as you've correctly noted. However, I will forward your request internally to the proper department. Hopefully you will see these improvements soon in a future version of the product. Thanks for sharing your requests, sir.



Link to comment
  • 0

According to the KB, the v1811 is supposed to work with v1809 (Non LTSC). However, I'm getting a message saying that a new disconnect button is already installed. This is pretty frustrating. Every time Microsoft does one of their automatic updates, it's going to break the 'fix'. There's got to be a more permanent solution.

Link to comment
  • 0

Just in case you guys want, I found a work around for this, you probably already saw it, but I created a shortcut on the desktop of all my VM's using login script, that creates an icon and runs the command "C:\Windows\System32\tsdiscon.exe" it's the old terminal server disconnect option, but it works perfectly for VM's. then I just pinned it to all my users taskbar. Hope that helps.. :)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...