Jump to content
Welcome to our new Citrix community!
  • 0

citrix pvs + the virtual machine with MAC address is the selected device collection could not be found on any available connection


Purushoth Ramu1709160019

Question

Hi All,

 

I have created a Device in the PVS and I have tried to Add Machines in the delivery group but I am getting below error message.

 

"The Virtual machine **-**-** with MAC address **-**-**-** in the selected device collection could not be found on any available connection."

 

We have verified  that the same MAC address is updated in both PVS and VMware and also updated the same in DHCP but even though we are getting this same error message.

 

Note:- MAC address has been changed, but updated the same in the DHCP and PVS. Hope, It might be because of cache entries stored in the PVS database. IF yes, please advise me how to remove those entries.

 

Please advise me on this,

 

Thanks

 

 

 

 

 

 

 

 

Link to comment

6 answers to this question

Recommended Posts

  • 0

Hi Raphael,

 

This is the log we are getting,

 

Error Id: XDDS:A75A86BB

Exception:
    Citrix.Console.Models.Exceptions.ScriptException The virtual machine **-**-** with MAC address **-**-**-** in the selected Device Collection could not be found on any available connection.
       at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.Scripts.AddPvsMachinesScript.RunScript()
       at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run()
       at Citrix.Console.ProvisioningSchemes.UI.Dialogs.AddMachinesWizardViewModel.Commit(IProgressReporter progressReporter)
    
    DesktopStudio_ErrorId : UnknownError
    ErrorCategory : NotSpecified
    DesktopStudio_PowerShellHistory : AddPvsMachinesScript
    8/27/2018 7:27:29 AM
    
    Set-PvsConnection  -port 54321 -server "**-**-**"
    Get-PvsVersion 
    Get-SimplePvsCollection  -collectionId @("89ff5eba-eb97-4974-8742-5a9f33d4cc85")
    Get-SimplePvsDevice  -collectionId @("89ff5eba-eb97-4974-8742-5a9f33d4cc85")
    Get-SimplePvsADAccount  -domain "**-**-*" -name "**-**-*"
    Get-HypVMMacAddress  -AdminAddress "**-**-*.Domain:80" -LiteralPath "XDHyp:\Connections\**-**-**-**-**"
    Get-HypVMMacAddress : The supplied credentials for the connection are not valid.
        + CategoryInfo : InvalidOperation: (:) [Get-HypVMMacAddress], InvalidOperationException
        + FullyQualifiedErrorId : Citrix.XDPowerShell.HostStatus.ConnectionInvalidCredentials,Citrix.Host.Sdk.Commands.GetHypVMMacAddressCommand.

 

 

 

Link to comment
  • 0

I ran into a similar error, XDDS:A75A86BB. It turned out that the the account we were using to connect to vCenter had permissions to the VM, but it could not browse the folder that the VM was in. I moved the VMs that were not working to the root of the folder structure and I was able to add them to the Machine Catalog. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...