Jump to content
Welcome to our new Citrix community!

Question

Hi,

 

I have an intermittent issue where when I launch an application it mirrors on both screens even though I can only use the application on one screen.  When I move the application around on the screen it should be on it mirrors on the second screen.  I have a number of other applications open at the same time however they don't mirror and the monitors are set to extend.

 

The only way I have currently been able to do this is log out and log back into the PC after closing.  The image below show's an example of this.  The left screen is the screen it works on and right is the mirrored screen.

 

Does anyone have any ideas on this as it's a bit frustrating.  We are currently upgrading from 6.5 to 7.15 LTSR using Citrix receiver 4.9.2000.21

 

image.thumb.png.852b6a2dbc83983f86e37df2244d3bae.png

Link to comment

9 answers to this question

Recommended Posts

  • 0

I have also tried the below but no luck

 

1.    Logoff all ICA session and exit Receiver
2.    Navigate to C:\Program Files (x86)\Citrix\ICA Client\
3.    Locate wfica32.exe and right-click it, choose Properties -> Compatibility-> check option "Disable display scaling on high DPI settings"
4.    Repeat step 3 for wfcrun32.exe
 

Link to comment
  • 0

If you have a support contract load a ticket and reference this bug ID: LC9893 and ask for the private fix. I spend many hours with Citrix, it's not confined to LTSR 7.15 CU2, it was happening on our old 6.5 farm during our migration to 7.15. The private fix only work with 4.12, they may have coded the fix for other versions, I do not know. ( I don't think you need to stay on the LTSR receiver to maintain LTSR compliance.

 

Now, I like the Browser Content Redirection and so does the business, looks like we're back on current track or whatever Citrix call it!!!

Edited by david2510
Extra Info
Link to comment
  • 0
On 3.8.2018 at 10:25 AM, Chris Kirwan said:

Hi,

 

I have an intermittent issue where when I launch an application it mirrors on both screens even though I can only use the application on one screen.  When I move the application around on the screen it should be on it mirrors on the second screen.  I have a number of other applications open at the same time however they don't mirror and the monitors are set to extend.

 

The only way I have currently been able to do this is log out and log back into the PC after closing.  The image below show's an example of this.  The left screen is the screen it works on and right is the mirrored screen.

 

Does anyone have any ideas on this as it's a bit frustrating.  We are currently upgrading from 6.5 to 7.15 LTSR using Citrix receiver 4.9.2000.21

 

image.thumb.png.852b6a2dbc83983f86e37df2244d3bae.png

 

experiencing the exact same issue with Window 1803 and Receiver 4.9.3000.11 (XD 7.6 LTSR CU6). Plan to update on to 7.15 CU* ... 
maybe a bug in the wfica32.exe itself or the underlaying OS stack ... 

Link to comment
  • 0
On 1/2/2019 at 9:28 AM, Chris Kirwan said:

This issue should now be resolved.  Citrix have released receiver 9.4 CU5 that should resolve this issue. 

 

https://docs.citrix.com/en-us/receiver/windows/4-9/about/fixed-issues.html

Can anyone confirm if CR 4.9 CU5 or CU6 resolved this issue?

The CTX article mentions its fixed in CR CU 5 and CWA 18.12.

 

So far it appears only CWA 18.12 resolves the issue.

 

Pete

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...