Jump to content
Welcome to our new Citrix community!
  • 0

XenServer 7.5 + NVidia P40 only Pass-Through


Szczepan Lewandowski1709152953

Question

6 answers to this question

Recommended Posts

You need to install a separate NVIDIA GRID license server as well as purchase licenses from NVIDIA or you will not be able to use vGPU profiles. The license server can run as an independent Windows or Linux appliance. It is totally separate from the VMs, themselves, which also require NVIDIA drivers to be installed on them. Please see https://docs.nvidia.com/grid/latest/grid-license-server-user-guide/index.html for details about the license server. I think you may need to do some more reading/research into how the various components interact for vGPUs.  Seach for "NVIDIA GRID installation guide" and download the http://www.nvidia.com/object/grid-vgpu-deployment-guide.html

deployment guide and also the installation guide. It's not such a trivial process, alas.

 

Also, you need an Enterprise or full XenApp/XenDesktop licensed version of XenServer to be able to run vGPU GRID VMs.

 

-=Tobias

Link to comment

i had the same issue and we had to disable ecc. it is enabled by default:

Resolution:
Use nvidia-smi on hypervisor to disable ECC:
1.       Install vGPU Manager on hypervisor
2.       Use nvidia-smi to verify ECC status
 # nvidia-smi -q
 3.       Disable ECC
# nvidia-smi --ecc-config=0

4.       Reboot the host
# shutdown -r now

5.       Check if ECC is disabled
# nvidia-smi -q

 

hope this helps someone out there

Link to comment

Yes, thanks for mentioning that, as well. One has to really go very carefully through the installation guide for the specific model of GPU, as there are some critical steps that may seem minor, and differ from model to model, but can make all the difference between success and failure.

 

That command should return something that includes lines like this:

 

    Ecc Mode
        Current                     : Disabled
        Pending                     : Disabled

 

-=Tobias

Link to comment
On 2018-08-20 at 11:41 AM, jose Villegas said:

i had the same issue and we had to disable ecc. it is enabled by default:

Resolution:
Use nvidia-smi on hypervisor to disable ECC:
1.       Install vGPU Manager on hypervisor
2.       Use nvidia-smi to verify ECC status
 # nvidia-smi -q
 3.       Disable ECC
# nvidia-smi --ecc-config=0

4.       Reboot the host
# shutdown -r now

5.       Check if ECC is disabled
# nvidia-smi -q

 

hope this helps someone out there

 

thanks for this suggestion. It was very helpful. It is described in grid vgpu user's guide:

Quote

Tesla M60, Tesla M6, and GPUs based on the Pascal GPU architecture, for example Tesla P100 or Tesla P4, support error correcting code (ECC) memory for improved data integrity. Tesla M60 and M6 GPUs in graphics mode are supplied with ECC memory disabled by default, but it may subsequently be enabled using nvidia-smi. GPUs based on the Pascal GPU architecture are supplied with ECC memory enabled.

However, NVIDIA vGPU does not support ECC memory. If ECC memory is enabled, NVIDIA vGPU fails to start. Therefore, you must ensure that ECC memory is disabled on all GPUs if you are using NVIDIA vGPU.

 

 The same tweak needed for Tesla V100 (by default ECC mode is enabled:

# nvidia-smi -q

==============NVSMI LOG==============

..............

Attached GPUs                       : 1
GPU 00000000:3B:00.0
    Product Name                    : Tesla V100-PCIE-32GB
    Product Brand                   : Tesla

..............

    Ecc Mode
        Current                     : Enabled
        Pending                     : Enabled

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...