Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Receiver 4.11 and above Outlook seamless minimizing


Björn Schläfli

Question

Hi all,

 

we've updated receiver 4.4 to 4.11. Since then we have the issue that seamless Outlook looses focus to local applications. My analysis showed it happens if you do the following order of application switching. 

Opened are Outlook (Citrix published application), Word or Excel (Citrix published application), e.g. local Internet Explorer. Minimize Word or Excel, click on IE, click on Outlook and click around a bit in calendar. After a few clicks it switches to the local application which was the last used (in this case IE). 

It only happens if you have the local application maximized in background and Citrix published Word / Excel minimized. If Word / Excel is maximized it's not happening.

If it happens sometimes you don't even need to click at all, just sit there open Outlook calendar and wait a few seconds.

 

It happens with Receiver 4.11 and 4.12. Uninstalled it and installed 4.4 again. The issue is gone. Installed back 4.11 or 4.12 issue's back again. 

I haven't tested 4.5 - 4.10. :-)

 

It's a XenApp 7.15 CU1, VDA 7.15 CU1, VDA's are 2008R2.

Link to comment

14 answers to this question

Recommended Posts

I've tested a lot. Same issue in another XenApp 7.15 CU1 site with Office 2010 seamless (other domain).

- It works in a desktop session.

- It works on same site with Office 2016.

- It works with XenApp 7.14.1, Receiver 4.11, VDA 7.15.0, Office 2010, VDAs 2008R2

- It works with XenApp 7.15.1, Receiver 4.11, VDA 7.15.1000, Office 2016, VDAs 2016

- It doesn't work with XenApp 7.15.1, Receiver 4.11, VDA 7.15.2000, Office 2010, VDAs 2008R2

 

-> At the moment it only happens on constellations with XenApp 7.15 and above, Citrix Receiver 4.10.1 and above, Office 2010. If you change Office to a newer version, Receiver to an older or XenApp to an older it works.

Link to comment

We experienced this issue and was able to implement a workaround (not fix) by launching the Oulook 2010 app, then right clicking the desired function (Inbox, Calendar, Contact, Tasks, etc...) then selecting 'Open in new Window' after the new window launches, the focus issue does not occur in the new window.  You can now close the original window and continue to use the new window without issue.  FYI..this will have to be implemented every new session until a permanent fix is found.

 

We are curently utilizing 7.15 LTSR CU2 and have tested many Citrix Receivers including Citrix WorkSpace and the issue persists.  We have a ticket opened with Citrix Support and can reproduce the issue for them, but until a fix is found we will continue to use the 'workaround'

Link to comment
15 hours ago, David Szekeres said:

We experienced this issue and was able to implement a workaround (not fix) by launching the Oulook 2010 app, then right clicking the desired function (Inbox, Calendar, Contact, Tasks, etc...) then selecting 'Open in new Window' after the new window launches, the focus issue does not occur in the new window.  You can now close the original window and continue to use the new window without issue.  FYI..this will have to be implemented every new session until a permanent fix is found.

 

We are curently utilizing 7.15 LTSR CU2 and have tested many Citrix Receivers including Citrix WorkSpace and the issue persists.  We have a ticket opened with Citrix Support and can reproduce the issue for them, but until a fix is found we will continue to use the 'workaround'

 

My experience is identical with Outlook 2010 specifically, would you be willing to post the case number so I can reference this please?

Link to comment
5 hours ago, Flo said:

I am interested if there was a fix for this issue as well...

I have 71.5 LTSR CU3 VDA on 2008R2 with 4.9 CU 5 Receiver and I am experiencing the same issue.  I looked for twi3.dll on the server and the only one is in the correct place (C:\Program Files (x86)\Citrix\System32) and is owned by Citrix (version 7.15.3000.218 10/23/2018)

 

Link to comment
On 2/12/2019 at 9:41 AM, Erik Wattnem said:

I am interested if there was a fix for this issue as well...

I have 71.5 LTSR CU3 VDA on 2008R2 with 4.9 CU 5 Receiver and I am experiencing the same issue.  I looked for twi3.dll on the server and the only one is in the correct place (C:\Program Files (x86)\Citrix\System32) and is owned by Citrix (version 7.15.3000.218 10/23/2018)

    It took a while but I got the private patch which replaces twi3.dll.  It seems to have fixed my outlook 2010 focus issue in development.  They said this fix will be included in 7.15.4000 which is scheduled to be released in the next few weeks.  Before the fix, we could make the focus issue happen if we did this:

- open outlook 2010

- make the notification box appear (schedule an appointment 15+ min out) then minimize it

- switch to calendar and mouse over an appointment so the "mousetips" show

- move the mouse off the calendar entry and outlook should lose focus and be sent to the back of your apps

 

Case: 78824482

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...