Jump to content
Welcome to our new Citrix community!
  • 0

PVS 7.15 CU2, can only boot from original target device (blue screen with CvhdMp.sys)


Stephen D. Holder

Question

Hello folks,

 

I’ve recently pulled a Hyper-V image and converted to VMware.  I then used the PVS imaging wizard to port the vdisk into PVS 7.15 CU2.

 

The vdisk is a Win 2012 R2. All the VM hardware from Hyper-V matches to VMware. The VMware side is running the vmx3 network adapter and the tools have been installed and up-to-date. I installed the PVS 7.15 CU2 target device software after the VM tools.

 

Everything went smoothly, expect for the fact that I am now unable to boot that vdisk, from any other target device. I am able to boot from the original target device (where I imaged from) but any other target device blue screens. I’m pretty sure I ran into this problem years ago.

 

What will happen when I try and boot from another target device is, It’ll load and when it displays the PVS info – but only the first line PVS 7.15.3.11  After a few seconds, it’ll blue screen with the

follow error-

 

Your PC ran into a problem and needs to restart. We’re just collection some error info, and then we’ll restart for you.

If you’d like to know more, you can search online later for this error: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (CvhMP.sys)

 

I have attached screen shots.

 

I want to say the fix years ago for this was either a reg key delete/ entry/ or a MS hotfix on the original base image..

 

Thoughts?

 

e1.png

e2.png

Link to comment

7 answers to this question

Recommended Posts

  • 0
8 hours ago, George Spiers1709154522 said:

Have a look here for some things to try: http://www.jgspiers.com/0x0000007e-bnistack-failed-vmware/

 

George,

 

I’m pretty sure this is the exact article I followed back in 2015. My issue was the ethernet0.pciSlotNumber (I already removed ghost nics.) After modeling that value from the working VM that did boot, I was good to go. But now I have follow up question…

 

Although this method works, do I now have to resort to a manual effort of changing the ethernet0.pciSlotNumber value to each target device? Which means remembering/documenting this value which will only be for this vdisk?  Or create a template and spin off VMs from that – again specifically only for this vdisk. FYI, I tried moving the vdisk to another non-edited ethernet0.pciSlotNumber target device and got the same result as before – which I’m guessing is expected? The last option is to entirely rebuild the vdisk on VMware but of course, the documentation for this vdisk and applications are nowhere to be found.

 

It’s an amazing fix, I just need to scale it without an asterisk if possible. I was hoping for some sort of registry entry to accomplish your ethernet0.pciSlotNumber fix, but it looks like yours is at the hypervisor level.

 

Also, how did you even come up with this? – What does your fix actually do? – remap drivers?

  • Like 1
Link to comment
  • 0
On 6/29/2018 at 10:52 AM, George Spiers1709154522 said:

Yes just create a template with the value set correctly, then your Target Devices would be created off that template which solves the issue.

 

The fix just sets the PCI slot number to the correct one, it was documented in a CTX article long before I documented it.

 

 

100%, absolutely true. It does solve the issue, but with a caveat of creating another template (and documenting why it was done with the proper numeric value) - which was the part I was trying to avoid. This organization already has so many templates for so many unknown reasons - it's a lot of clutter. I don't want to add to the pile for yet another image - but I do need to move forward.

 

The immediate and instant fix is to use this solution. The ultimate fix would be to rebuild the image on the VMware hypervisor. None the less, you solved my issue and have marked your answer as correct - Thank you.

 

I'm more curious, but what causes the PCI slot number to change like that?  Is it just booting/transferring from another hypervisor -- the constant recycling of vdisk images? If you have that original Citrix article I'd like to take a look at it. I'm almost wondering if it's possible to re-transfer the vdisk from Hyper-V to VMware with some setting(s) checked on the Hyper-V side that'll allow the PCI value(s) to align up correctly with VMware.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...