Jump to content
Welcome to our new Citrix community!
  • 2

7.18 Issues

Riley Foster


We've been trialing 7.18 (upgrade from 7.17) and have run into a few issues. Anyone else?


1) We do a double-hop. First hop is a shared desktop with some local and some published apps. Published apps seem to be quite a bit slower/sluggish. Launching, moving around, etc. all seems to be slow. Local apps on the shared desktop seem to still be acceptable, but still may be slower.


2) Desktop icons flickering. Not sure yet what causes it but all desktop icons start flickering and the user seems to be unable to launch additional published apps. Also existing apps can't be closed and sessions can't be logged off without "coaxing" from director/task manager.


I've rolled-back to receiver 4.11 on the shared desktop to see if that helps either issue.


I have been working with support on these issues but we've only begun.


FYI - we're trialing 7.18 because is looks like 7.17 might still be affected by the bug where users get disconnected from their sessions when the Citrix policy/RSOP refreshes. We had a number of reports from users where they were being disconnected in the middle of using an app. Event logs show a policy refresh then three or four sessions would be disconnected immediately after. There is a fix for 7.15 and 7.16, but nothing for 7.17.



Link to comment

Recommended Posts

  • 1

Quick update. I worked with support for a few hours last Thursday and we were able to reproduce and log the two main issues we're having:


1) Desktop icons flickering. This seems to happen on a disconnect/reconnect although a number of users have reported it just starting in the middle of a session. Downgrading back to receiver 4.11 did not resolve it. I ran Process Monitor and I can see explorer.exe continually enumerating each folder in the path up to C:\Users\username\AppData\Roaming\Microsoft\Windows\Themes\CachedFiles. It does this dozens of times per second continually.


2) Apps fail to launch and make the session unresponsive. This seems to happen mainly when a user opens an app via FTA. Using the desktop icon seems to be OK most of the time. When the issue happens the Citrix launcher will come up after a couple minutes even though it should be session sharing with an existing session. Also logging off of that session will hang and the user cannot launch any more apps until the hung session is cleared out.


We collected logs on Thursday and I was told that I would hear back in 24-48 hours. I phoned back this morning and was told that the data still had not been analyzed. 


Case #77743196 for anyone else having the same issues.

  • Like 1
Link to comment
  • 1

We ended-up having to uninstall the 7.18 VDA and use the 7.17 VDA with the "black screen" UPM fix. This resolved all the major issues. Speed is back, icons don't flicker, apps launch consistently, etc. Also, I did an uninstall/install of the VDA and took new snapshots - I did not roll back snapshots - so these 7.18 issues aren't related to something else that changed.


I finally received a reply this morning. Their recommendation is to use the 4.9 CU3 receiver because it includes the following fix:


The Start menu and taskbar icons might flicker when you refresh the applications within Citrix Receiver for Windows. [#LC8890]


However, this exact fix is already included in receiver 4.12 - which is included with the 7.18 upgrade.


I mentioned the above and that we have no more issues with the 7.17 VDA and received a reply asking if we wanted to close the case since we had no issues.


Not impressed.





  • Like 1
Link to comment
  • 1
On 8/1/2018 at 9:51 PM, IT Dept1709152990 said:

Same here. 7.17 to 7.18 Server 2012r2. Seamless apps are lagging and input is delayed.

This seems to fixed our issues so far for lagging apps:



DWORD: SeamlessFlags

Value: 4 (Disabling Active Accessibility hook) 



  • Like 1
Link to comment
  • 0

Hello Riley,


thanks for the summary. We have exact the same problems (without double hop). We came from 7,.17 and make an inplace upgrade to 7.18 on Windows 2012 R2. 


1.  The start of a Desktop/App is much slower than before (especially hang on UPM Profile Loading)

2. Work with a pulished App is inacceptable. Extreme slow screen refresh, slow opening dialogs,...

3. Work with a pulished Desktop (after login) is okay but slower as before

4. Citrix Policy Upgrade disconnected active user sessions


After uninstall 7.18, VDACleanUpTool und reinstall 7.17 Point 1-3 are resolved.


Best regards,



Link to comment
  • 0

I almost forgot, we’ve experienced the black screen issue on 7.17 as well. The app readiness service seems to have issues and users just get a black screen. RDPing to an affected machine gives a black screen as well. So far we haven’t seen this on 7.18 - which is thankfully one of the issues that was to be resolved. 


I’ve also seen the black screen when closing an app. It goes away after a couple seconds though. 


We’ll see today how the 4.11 receiver works. We can live with slower performance (for some time) as long as the icons stop flickering and users can actually launch apps. 

Link to comment
  • 0

Been back and forth with support - they still want us to use the 4.9 CU3 receiver, citing fix #LC8890 and article https://support.citrix.com/article/CTX200830.


LC8890 is already included in receiver 4.12 - which was installed already with the 7.18 upgrade - and CTX200830 doesn't seem to have anything to do with our issues. 


I'm not going through the upgrade and testing process again until we get a better answer.

Link to comment
  • 0

I ran into the same issue this past week.  We are running Windows Server 2012 R2 VDAs with all published application and the performance was awful.  The screen painting made the apps unusable so we went back to the 7.17 and the 7.15 CU2 UPM fix and everything was back to normal.  I wanted to try the new OST/Windows Search function but that's out now.

Link to comment
  • 0

We also just did the 7.12 to 7.18 and office 2016 was slower than molasses.   Dropped one of our servers VDA to 7.17 and that fixed.   We also tested the SeamlessFlags registry add above and that also works if you want to remain on 7.18.   It was easier to push a regmod via GPO than to downgrade to 7.17.    Hope CTX finds a fix soon.  Tested on 2012R2 server, receiver is latest.

Link to comment
  • 0

Same issue here in XenApp 7.18

VDA 7.18

Server 2016

Receiver 4.12


Desktop is fast with all apps

But Published Apps are slow and sluggish

We have the "black frame" around the apps and all menu settings in the application are slow


We have tested the RegSettings with Seamless Flag and it seems to be a little bit better but this is no solution to work with published apps.







We also tested the RegKey from the following CTX article, but even that was no solution.






We also have tested the follwing settings from this forumpost



WorkerWaitInterval=dword:500 (Dezimal)

WorkerFullCheckInterval=dword:5000 (Dezimal)


Also no solution.


Has anyone a solution for this issue?




Rollback VDA to XenApp 7.17 and delete the above RegKeys


Now the seamless Apps run better, not sluggish or slow.

But now we can not maximize the app after we have minimized the app.

We ca see a light black frame around the app but not so strong as before.


So it seems to be the XenApp Server VDA 7.18




Link to comment
  • 0

Having very similar issues. Upgraded to 7.18 to resolve the black screen issue with 7.17. After this, published applications are slow, things like doing a right click on a cell in Excel takes seconds before the menu pops up. Running Excel from within a published desktop works as it should, right click is fast (immediate).


Tried with Receiver 4.11 and 4.12.


When is 7.19 due out?






Link to comment
  • 0

I'm testing from going from 7.6 to 7.18 for our Windows 2012 R2 XenApp desktops and we get a black screen and when we eventually get to the desktop and then go to the start menu when all the Metro Tiles are, well we are met with a blank screen.  If I type the name of an app then everything will appear for the session.  Then if I log off and back it I get the same issue.  Not sure if I should try the latest LTSR....

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...