Jump to content
Welcome to our new Citrix community!
  • 0

OneDrive Files On Demand 1709 error


J.P. Marshall

Question

I am using a 1709 image on our non-persistent layered pool and tried to enable files on demand.  Now I am getting an error that says "OneDrive cannot connect to Windows".  I have tried the reset trick and it has not helped.  I have also tested on a non VDI machine and it works fine.

Link to comment

14 answers to this question

Recommended Posts

  • 0
On 6/5/2018 at 7:46 AM, J.P. Marshall said:

I am using a 1709 image on our non-persistent layered pool and tried to enable files on demand.  Now I am getting an error that says "OneDrive cannot connect to Windows".  I have tried the reset trick and it has not helped.  I have also tested on a non VDI machine and it works fine.

Anyone else seeing this issue or have any suggestions?

Link to comment
  • 0

The OP doesn't mention whether he's using Elastic Layering (EL) or not.  If you have EL set to None, then the published image should be like a clone of your Gold VM.  We will have virtually no software running on it.  It would be useful to know, all other things being equal, if this problem goes away with EL set to None.

 

Make sure you're on the latest version (and we're about to drop another one this week, so upgrade to that) just to make sure you're testing on the latest.

 

Unfortunately, I don't know technically what Files On Demand actually does or how it's implemented, or even what the "reset trick" is, so I'm not going to have any kind of substantive answer.

Link to comment
  • 0
On 7/16/2018 at 8:50 AM, Gunther Anderson said:

The OP doesn't mention whether he's using Elastic Layering (EL) or not.  If you have EL set to None, then the published image should be like a clone of your Gold VM.  We will have virtually no software running on it.  It would be useful to know, all other things being equal, if this problem goes away with EL set to None.

 

Make sure you're on the latest version (and we're about to drop another one this week, so upgrade to that) just to make sure you're testing on the latest.

 

Unfortunately, I don't know technically what Files On Demand actually does or how it's implemented, or even what the "reset trick" is, so I'm not going to have any kind of substantive answer.

We are using EL in the image.  I can try to turn it off to see if that makes a difference.

Link to comment
  • 0
On 7/31/2018 at 9:26 AM, J.P. Marshall said:

We are using EL in the image.  I can try to turn it off to see if that makes a difference.

We are continuing to have this issue.  I have now upgraded to 1803 and it is still having the issue.  I have tried it by just logging into the image VM directly as it came out of the app layering and it works fine there, so I am guessing it must be a profile issue somewhere.

 

Anyone else have luck with this?

Link to comment
  • 0
On 3/6/2019 at 9:26 AM, Eric Gilliland said:

Hi, are you still experiencing the issue? I'm running Win10 1803 AL 19.1.0.17 with Elastic User layers enabled and see the same error when FoD is also enabled. When I publish the identical template, but with EL disabled, the problem is gone. I'll open up a ticket as well.

I've since opened a support ticket, and they confirmed it's a problem. My ticket number is 78770656 for anyone curious.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...