Jump to content
Welcome to our new Citrix community!
  • 0

Fails to Create new VM - Error Locking Pool XXXXX


Question

Hope someone in here has seen this before, but i'm not finding much in the way of help out on the big bad internet.  We have XD 7.6, with XenServer 7.1 on the back end. Two DDCs in the farm.  We previously provisioned successfully static, persistant desktops.  Fast forward a year plus.  We want to deploy more machines to the catalog.

 

I updated snapshot for the catalog using Powershell so we could use a newer snapshot.  But that's irrelevant here, b/c even before that I had the issue.

 

When adding new machine, through the GUI, able to step through the process of number of machines, creating new machine accounts in the domain (or using existing machine accounts), and when ready---click OK.   Wheel spins, and then it goes back to the Studio screen.

 

No errors show on the catalog, but when i check the Logging section of studio for a task update, it says the task failed.  If you scroll through the details at the bottom, the task "Locking Pool XXXXXXXX" showed FAILED.   The "XXXXXX" is replaced by the hosting resource that is used for the Catalog.

 

Further troubleshooting---Created a new resource pool that used similar resources on the same XenServer pool, so now i'm using a newly created resource pool, new MC....selected existing snapshot , and still fails with the same error.   For kicks and grins, went to another catalog that uses a different pool of XenServers, and receive the same error.  So it's definitely ruled out the XenServer (potentially) side.  The only variable there is that the Hypervisors were 6.5 originally, and have since been upgraded to 7.1.  

 

We have multiple networks with simliar setups, and not seeing this issue on other networks.  

 

I've run Get-ProvTask -Active $true to see if there are tasks running that locked the pool, and there are none.  Hypervisor connections look good and active.  Any suggestions on where look from here.  I'm about at wit's end.

Link to comment

5 answers to this question

Recommended Posts

  • 0

Thanks for the reply Jonathan.  II am currently in the process of recutting new certificates since all the connections were setup using HTTPS.  On a whim---i tried something that gave me "failed to connect" to the hosts...and some hosts of the pool had to be completely rebuilt (not just upgraded)--so i'm in the process of getting new certificates for all pool members for each pool we run.  If that doesn't solve the issue--then i'll try what you said and create new hosting connections.  

 

Thanks for the response!

Chris

Link to comment
  • 0

Hi Tuomo,

I did eventually get it resolved---and it ended up being an Active Directory permission when it attempted to create the computer account/or reset the computer account password in AD---my admin account didn't have the correct permissions on the OU to make the change against the AD object.  Once that was squared away, the issue went away.  It was harder to troubleshoot given that vague error....not the typical "access denied" i've seen when it's been an OU permission.

 

Good luck.  Update here if you find it's something else.

Link to comment
  • 0

Hi cdubs76,

 

Thanks for sharing! I got this resolved as well and in my case the root issue was that one of my controllers had low disk space which also prevented a Windows KB from getting installed while the KB had installed without issues on the other controller. I have to say I felt pretty stupid when I noticed the disk space issue and sent a pretty angry message to our monitoring team. :D

 

Happy Holidays!

 

-Tuomo

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...