Jump to content
Welcome to our new Citrix community!
  • 0

XenApp Services URL not working with Storefront 3.14


Walter B

Question

Good day,

 

We have been using XenApp 6.5 to publish apps to users and we now want to upgrade to XenApp7.  Most users use the legacy Citrix Online Plugin to access the apps and that must stay unchanged.

 

I have set up a new environment with XenApp 7.17 and Storefront 3.14 and I have enabled XenApp Services Support in the Storefront. However, the Online Plugin just doesn't see the XenApp Services site - it keeps giving the error:  "Citrix online plugin could not contact the server entered. This may be because the server is down, there is an error in the configuration file from the server, or the details entered are incorrect"

 

Note that the web site works fine with Citrix Receiver for Web - can successfully log in and access apps.

 

The Storefront provides the following XenApp services URL:  http://server/Citrix/store/PNAgent/config.xml .  As a test, I tried putting in the XenApp services URL in my browser to see if it can read the config.xml file, but then I get this error on the web page: 

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

 

I searched for a "config.xml" file in wwwroot, but there is nothing. So it seems that Storefront did not create the config.xml file.

 

I've been through the documentation and I have checked everything I know to check and can see nothing wrong with the setup.

 

I would really appreciate any advice.

 

Many thanks.

Link to comment

2 answers to this question

Recommended Posts

Good day, I did not get an answer here, but I eventually managed to fix the issue by just double checking all my settings and creating a new store with XenApp Services support. After this, all worked correctly.

One important thing is to make sure the TCP port is correct as specified for the Delivery Controller in Storefront. If the port specified in the Storefront is different from the port specified on the VDA, it will not work. Feel free to let me know if you need some guidance on this.

Hope you come right!

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...