Jump to content
Welcome to our new Citrix community!
  • 0

VDA LTSR CU2 failing @ MS Visual x86 C++ 2013, vda won't register


Stephen D. Holder

Question

Greetings all,

 

I've been trying to install 7.15 LSTR CU2 for a while now and keep running into the attached error: Failed to configure component 'Microsoft Visual x86 C++ 2013 Runtime' because it is not installed

 

Of course if you look right above, it says it installed successfully.   Bottom line, when this happens the VDA won't register and when I try and manually start it from services I get the Start / Instantly stop service.

 

I've tried an in place upgrade - same results

I've ran the VDA clean up utltiy and then fresh VDA install from the CU2 iso  - same results.

 

Anyone run into this issue?

 

Thanks.

2018-05-17_11-12-54.png

Link to comment

4 answers to this question

Recommended Posts

  • 0

Hi Krishna,

 

No I don't have the logs, but I did some more troubleshooting and attempted the whole process again -- VDA clean up agent and all. I still got the Visual x86 C++ 2013 Runtime error at the end of the CU2 installer, but the eventually the service started and was able to register with the DDC. To make sure it wasn't a fluke, I stopped and started the desktop service at will - which it was now doing no problem. Before it wouldn't even start at all - and would just start/stop instantly. Not sure what change, or what I did differently. I have some other CU2 updates I have to do, so I'll try and report back their findings later.

 

One thing for sure is, all my testing I've been getting that Visual x86 C++ 2013 Runtime  error at the end of the CU2 installer.

 

Link to comment
  • 0

Its difficult to actually pin point on the root cause of the issue without proper logs, specially in case where we are unable this reproduce this in house. I am glad that you got it worked upon retry for now..and I would be keen on seeing your findings after your next updates. Please try to save the logs. 

 

Also, you might want to try this tool Citrix MSI log analyzer - https://support.citrix.com/article/CTX229734 that might help to gather more info. Keep us posted! 

Thank you. 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...