Jump to content
Welcome to our new Citrix community!
  • 1

XenDesktop 7.15 CU1 - MCS / RDS licensing issue


Question

Hi all,

 

I don't believe this is a Citrix issue, but I am using as the title says - XenDesktop 7.15 CU1 MCS to create 10 2016 servers to host an application for our staff.

 

I have noticed when I push an update/reboot with MCS that sometimes 1 or 2 of the servers will not let me in complaining that there are no RDS licensing servers.  I went into the console for one of the affected machines via XenCenter and was able to see the policy I have is applied and shows the correct RDS licensing server.  I can get out to the license server from this VDA, etc.  Also note the other 8 or so servers that come back up after the update/reboot are fine.  If I then reboot the trouble server again, it comes back up and registers with the license server and we can get back into it.

 

Have any of you seen this behavior?  I don't understand it - especially since I checked the troubled machines and they show the correct RDS license server from our GPO!  

 

Others have suggested deleting the grace period registry key on the master - is that really the solution in this case with 2016?  Will it be solved for good?

 

I tried to troubleshoot this with Microsoft, but their solutions needed to reboot the affected machine...and in this case when these reboot they revert back to the master image so not really a good way of troubleshooting.

 

Any feedback would be great.  Thanks!

Link to comment

9 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...