Jump to content
Welcome to our new Citrix community!

ERROR Address already in use


Sandy Williams

Recommended Posts

Hello, trying to migrate a VIP from one VPX to another VPX.  I deleted the VIP from the old VPX and adding it to the new VPX (after removing the IP I  tried pinging it and got nothing).

 

add lb vserver Storefront_LB_VS SSL x.x.x.x 443
ERROR: Address already in use
 

I also tried 'show arp' on the new VPX and saw the IP so I removed it from ARP.

 

I'm at a loss now.. I gave up and added the IP back to the old VPX because I'm wasting a lot of time.  The new VPX is running the very latest firmware - NS12.0 Build 57.24. The VPX that was my old one is running a few minor builds older..

Link to comment
Share on other sites

  • 1 year later...
On 4/24/2018 at 4:10 PM, Sandy Williams said:

Yes, on both I ran 'sh run | grep "< ip address>"' and there's nothing (after I removed it from the old VPX)

 

Ok. so I figured it out. The Netscaler apparently creates a system service under the hood when you use a domain name in the session profiles. I was able to reuse the IP by unbinding the session profiles from Gateway and also editing the session action -wihome value with a fake url.

 

Once I changed the session action to a temporary bogus url, it allowed me to reuse the IP.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...