Jump to content
Updated Privacy Statement
  • 0

Elastic Layers and Profile issues


Craig Blodgett

Question

We're having a really frustrating time trying to deploy applayering in our environment. Everything works fine, except, if we try to enable elastic layering on an image, it breaks our user profiles. (can't open the start menu, everything really bogs down)

 

example, I can take the exact same template, deploy it without elastic layers enabled everything works great, enable elastic, profiles break. I don't even have to elastically assign layers to it, just the fact that it's enabled.

 

here's our environment

 

applayering 4.10

server 2016 OS layer

PVS/VDA for the platform

running on VMware.

 

UPM, roaming profiles, profile disks, doesn't matter it breaks them all.

 

I've got an incident open with Citrix, but so far haven't had any useful information.

 

Has anyone seen this before?

Have any suggestions?

 

 

Link to comment

Recommended Posts

We ultimately had to drop to 4.9 to get another 1607 image out.  4.10 was definitely the big breaker.  Some improvements came in 4.11, however left us with a bluescreen any time profile streaming and app layering were both enabled.  We sent them a few dump files and they were able to pinpoint the trigger and were working to get a fix into an upcoming release.  I'd say hang tight and we may have a fix soon.

Link to comment
8 hours ago, John Wolfe1709152557 said:

We ultimately had to drop to 4.9 to get another 1607 image out.  4.10 was definitely the big breaker.  Some improvements came in 4.11, however left us with a bluescreen any time profile streaming and app layering were both enabled.  We sent them a few dump files and they were able to pinpoint the trigger and were working to get a fix into an upcoming release.  I'd say hang tight and we may have a fix soon.

 

Thank you. We will use static layers until the fix is released. It's the only way for us to logon fast and don't break the profiles.

Link to comment

jwolfe14

On 5/31/2018 at 4:54 PM, John Wolfe1709152557 said:

Until this past month we've had app layering enabled and UPM Profile Streaming enabled, no problems! That's on AppLayering 4.9.  With our May image, which also updated to AppLayering 4.10...  That's when everything others are describing in this thread hit us.

 

For both our April and May images:

Win 10 1607

Desktop VDA/UPM at 7.15.1 LTSR

VMWare hosting (v6)

 

The only change from April to May is the bump from AL 4.9 to 4.10 and the obvious MS monthly rollups in the OS layer.

We also have a case open with Citrix where we were instructed to disable UPM Profile Streaming.

 

Unfortunately for us in our testing it actually increases login times for many profiles by about 7x..  so say a larger profile user had a login of 1.5 minutes, would become 10 minutes.  We actually enabled profile streaming early last year to help login times.  We've of course gone through the obvious review of upm file/folder exclusions and use folder redirection where possible, but that only goes so far. 

 

For us, disabling UPM streaming is just not possible, as it would render login times unbearable.   Disabling app layering is also not possible as we are heavily dependent on it for our myriad of tightly controlled/licensed apps.

 

We've escalated this issue with our TRM(technical resource manager) and the PMs(project managers) for both UPM and App Layering, just to express the importance of a true fix to our organization.  We realize its likely a complicated interaction and fix, and we're glad to have the attention to the issue.

 

While we wait, we're internally testing a rollback of the AppLayering tools in our May image back to 4.9 to make sure the 4.9 to 4.10 is not just a co-incidence.  We also still have ALA appliances on 4.9 and may output a complete image re-doing the other May MS updates.  I'll try to post back here once we have more information.  I know some Citrix contacts are represented in this thread, please share any insights or progress on this issue that you can.  Any info is appreciated.  ty  :-)

 

 

jwolfe14, do you have any update on your progress after rolling back your App Layering tools/drivers? Have you heard from Citrix support regarding your case?

Link to comment

I can confirm that UPM streaming profiles works in 4.12, however, Microsoft User profile disks still do not work with elastic layers enabled. 

 

Since applayering uses user layers which is basically the same thing, I don't anticipate this being addressed. 

 

We can't use user layers as they aren't supported on server os's yet, so profile disks worked really well. 

 

 

 

Link to comment

firstpoint,

I do have what sounds like a similar problem although it depends on what you mean by "not working".  I am using FSLogix Profile Containers for profile management also.  I find this is working fine with disk made without Elastic layers enabled (provisioned via PVS).  But if I build the exact same disk but with Elastic layers enabled the machine appears to work ok initially but overtime (couple hours?) slows down to a nearly unusable crawl.  Machines that are freshly booted are ok.  Any that have been rebooted but sitting idle for a few hours (as in first thing in the morning) are virtually impossible to logon to.

 

For now I am doing without Elastic layers but I would like to figure this out and fix it.  (Was looking around for clues which is how I bumped into your post.)

 

/David

Link to comment

Hi Rob,

I have struggled with the PVS cache disk filling in general.  I have worked to find and eliminate spurious writers though I find this much more difficult in Windows 10 than in Windows 7.  Windows 10 just seems very talky.  Mostly I have resorted to increasing the size of the write cache drive.  Up to 15gb now.

 

I hadn't noticed a correlation between elastic layers enabled and cache disk filling but I might not have been paying attention at that time.  Sometimes the blinders get on.  I will check into that.  Thanks.

 

Yeah, I will open a ticket if I cannot find enough clues by poking around here to figure it out.  Sorta hated to respond into a months old thread on a somewhat different topic... but also was interested that firstpoint had something <possibly> similar.

 

Thanks,
David

Link to comment

Our issue is different. Elastic layers are OK and performance is OK. We do not use PVS or RAM CACHE, MCS only. Problem is with new user, profile disk is created but user profile is not created. Exisiting users, profile is loaded but new settings are not saved to the profile disk. Looks like filter drivers competes with each other like described here: https://support.citrix.com/article/CTX234619

 

Maybe this is the problem https://support.fslogix.com/index.php/component/fss/?view=kb&catid=7&kbartid=92

Trying this out now. 

Link to comment

The altitude setting fixes Elastic layers + FSLogix

  • Edit HKLM\System\CurrentControlSet\Services\frxdrvvt\Instances\frxdrvvt\Altitude
  • Set the value to 138010 (Note: do not set this to any other value. Spurious results make occur. This value has been assigned to FSLogix by Microsoft)
  • Then reboot
Link to comment

Magnar,

Thanks.  I have the altitude setting already.  That was required to get the basic functionality going.  It works... it is just slow.  I can setup two machines with identical published images except for the inclusion of Elastic Layering the 2nd.  The 2nd will operate dramatically slower.  (And I confirmed it is not PVS Cache drive filling up.  Several gb free.  Still searching.)

 

/David

Link to comment

As an update, the citrix rep emailed me over the weekend stating that.

 

"The UPM streaming feature is incompatible with App Layering Elastic Layering because the filter drivers compete with each other and there is the conflict."

 

so I've disabled that on my sessions, so far not luck, but I thought I would pass that on.

Link to comment
26 minutes ago, Rob Zylowski1709158051 said:

Vmware persona management is incompatible with app layering. You would need to use environment manager in a vmware environment

 

Sorry, I wasn't clear, we're not using Persona Management. Using Citrix Xendesktop 2016 OS with Citrix User Profile Management, as a test I've also set up regular roaming profiles in Active directory and Microsoft profile disks. Same issue in each environment.

 

Link to comment

Is it possible you have a domain policy blocking access to removable drives?  I remember seeing a case that had policy that forced all external disks to read-only (targeted to USB disks, but it also wound up applying to VHD files as well) that got really unhappy when the User Layer disk was attached.  And one of the symptoms was that the Start Menu broke.  I'm not skilled in GPOs, so I have no idea what the exact policy was, but if possible you might want to test the platform layer being in an OU with inheritance disabled just to see if it's a domain policy.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...