Jump to content
Welcome to our new Citrix community!
  • 0

Unable to create Citrix XenDesktop Essentials resource in Azure (BadRequest error)


Jeffrey Goettsch

Question

Each time I try it fails after 5-10 seconds with Code: BadRequest, and an empty Message.

 

I'm at a university. At the end of each quarter we turn off XenApp Essentials to save money and turn it on again at the beginning of the next quarter. This is our fifth quarter and the first time we've encountered this issue.

 

I thought it might work to just delete everything and start again. So I tried to remove my subscription in the Citrix portal and it is now asking me for an admin account (in Azure AD) to do so. This was never required before. Looking through the XenApp Essentials Deployment guide, it says an Active Directory Global Administrator account is required to link an Azure subscription to a Citrix account, but this was never the case before - I've always been able to link my Azure subscription to my Citrix account using either my unprivileged account or my limited administrator account.

 

If a global administrator account is required I may not be able to do it.

 

Any ideas?

Link to comment

6 answers to this question

Recommended Posts

  • 0

Could you elaborate on what you were getting a BadRequest response from.  Although, if you already deleted your objects, I am not sure what else can be done...

 

I am not sure how your unprivileged account worked previously.  We did make some changes to the way we register with your subscription, but that was for our app to require less permission (app went from admin to contributor role).

Link to comment
  • 0

Sure. In Azure:

 

Click "Create Resource" in the sidebar. Choose "Citrix XenApp Essentials" and click the "Create" button. Do the usual steps: give it a name, choose my subscription and resource group, connect to my Citrix account, specify number of users, etc. and click "Create."

 

I then get the normal popup saying "Deployment in Progress" and then a few seconds later a popup saying "Deployment Failed." I click that and the full message is: 

 

Quote

 

ERROR TYPE

At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details. (Code: DeploymentFailed)

ERROR DETAILS

 

 

I can click for more details and it says:

 

 

Quote

"message": "{\"Error\":{\"Code\":\"BadRequest\",\"Message\":\"\"}}" }

 

That link in the first message says when the code is BadRequest to check the Message for details, but as you can see in the second quote, the Message is empty.

Link to comment
  • 0

Oh so you are talking about removing the subscription to XenApp Essentials from Azure Portal.  I thought you were talking about linking an Azure Subscription within the XenApp Essentials UI.  I am not familiar with the billing systems.  You might want to contact support.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...