Jump to content
Welcome to our new Citrix community!
  • 0

WS2016 / VDA 7.15 LTSR - Logoff not completing


Liam Cooper

Question

Afternoon,

 

We are encountering some strange behavior with our Virtualised Windows Server 2016 servers,

More often than not when a user tries to log out of their hosted desktop the session will present the 'Signing off' screen and never manage to completely log out. Instead 10/13 processes will remain running and the session will stay in an active state (seen from both Studio, Director and task manager)

From this point the only option seems to be manually signing the user off (again with Studio, Director or task manager)

 

If the user then tries to log back in a new session can be launhced, with the old being ignored. This then produces a second profile as UPM has not initiated the logoff process due to the first session remaining active.

 

Annoyingly there is probably about 5% chance that the session will logout successfully too

 

The processes we are typically seeing running after the user logs off are:

 

-- Sihost.exe (terminating this brings alot more processes back)
-- Svchost.exe
-- Taskhostw.exe
-- Wfshell.exe (terminating this closes the session)
-- Explorer.exe
-- RuntimeBroker.exe
-- ShellexperienceHost.exe (Suspended)
-- SearchUI.exe (Suspended)
-- Csrss.exe
-- Winlogon.exe
-- dwm.exe

 

As stated above terminating the Wfshell.exe process manually also closes the session.

I can add this process into the 'HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI' 'LogoffCheckSysModules' key and the session logs out, I just feel that this is probably not the best option as this is basically bypassing the process that wfshell runs through, so im basically telling it to ignore itself?

 

Its also worth mentioning that after about a minute of the session trying to log out i get the following event logged:

 

Winlogon - the windows logon process has failed to terminate the currently logged on user's processes - Event ID 4004

 

Ive tried killing all of the remaining processes one by one to see if any others result in the session logging out but other than wfshell.exe none do the trick,

im assuming that due to the fact that wfshell is the process holding the session open its most likely because its trying to close a different process?

 

Process monitor didnt show up a great deal either but in my defence, im not as proficient as i should be with the procmon tool.

 

Any ideas or help would be greatly appreciated.

 

Regards,

Liam

Link to comment

4 answers to this question

Recommended Posts

  • 0

Connections over RDP are fine, Its just when using citrix. Issue persists over multiple citrix methods too (HTML, IOS, multiple releases of the Receiver for Windows)

 

The servers don't have any security software installed either.

 

Actually seeing as your mentioning drivers, one of the similarities of the servers we are seeing with this issue is that they all reside on a Xen host running GPU passthrough with a NVidia GRID k2, So potentially the graphics driver could be playing a part in all of this - this would also marry up with RDP not being effected.

 

Ill give this a look and report back

Link to comment
  • 0
On 4/5/2018 at 7:33 AM, Liam Cooper said:

Updating the NVIDIA Driver to its latest release solved this issue,

 

Thanks for your help

 

I have similiar problem since I upgraded my NVIDIA M10 drivers to 443.05 (vGPU 10.2). Which version fix your issue ?

 

Also running on Windows Server 2016 with CVAD 1912 LTSR (problem exists with and without CU1) but the probability is very low (less than 1%) and the support team can force logoff via Director. As I see, Wfshell.exe is not running while the issue occurs and kill remainning processes won't force the logoff so LogoffCheckSysModules not concerned.

 

csrss.exe
winlogon.exe
dwm.exe
sihost.exe
explorer.exe
fontdrvhost.exe (not always present)
svchost.exe
taskhostw.exe
taskhostw.exe
LogonUI.exe
NVDisplay.Container.exe
DirectorComServer.exe

 

Regards,

Kévin

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...