Jump to content
Welcome to our new Citrix community!
  • 0

"Connection in Progress" stuck issue, after updated Windows KB


Hk Ito

Question

Hi Everyone,

 

we triggered have some users reported when they have update the KB4089510 on 22-3-2018 (which is user PC as Windows 10 ver. 1607 64bit, pushed by WSUS).  The Citrix receiver has been failed to connect, only show the loading bar and "connection in progress" then retry, either open XENAPP or VDI also failure.

After failure to connect the xenapp, Citrix receiver shown "The network connection to your application was interrupted. Try to access your application later, or contact your help desk".

 

We tried below tests but not help of the case:

1. disable session reliability connection from client (i.e. amend ICA file remove *.2598 data from CGPaddress = )

2. enable DNS resolution policy at xenapp server

3. using citrix cleanup tools to uninstall & reinstall several version of Citrix Receiver (4.3, 4.9.100, 4.9.200, 4.7 or 4.11)

4. change window's network provider order

5. disable / enable IPv6

6. using Citrix quick launch to access but failure

 

All problem PCs were checked:
Telnet 1494, 2598 have response
Disable / enable windows firewall / anti-virus software / proxy setting
ICA file can be download from Google  chrome, thru "Receiver for Chrome" can open the published applications
IE proxy setting is verify can access the Citrix Server, tried to set trust site for Citrix web address 
Remote desktop to Citrix server can login to RDP remote session
User profile have administrator right

 

Meanwhile, some windows 7 users also reported same issue, the case is after updated Windows KB dated on 15-3-2018 pushed by WSUS, we tried any action likely as upper said but still failure.  Windows 7 KB numbers were here:

kb2952664
kb4089187
kb4088878
kb4088875
kb4074598
 

On temporarily, end user only thru restore point to return before install KB status to bypass the problem.

 

Remarks: only this kind of user cannot be connect from their PC, other users can normal access. Even we tried to use the problem users' Citrix login account in our lab env. also can be connect success.

 

Would anyone have idea to troubleshoot the case? Since we still have many off-site users using our system, if anyone updated the windows caused the connection problems, we don't know how to fix it.

 

our environments:

XenApp servers farm - Windows 2008 R2, Xenapp 6.5

VDI servers farm - Windows 2012 R2, xendesktop 7.6 with Netscaler

Clients OS: windows 7, windows 10 ver 1607

 

1.png

Link to comment

7 answers to this question

Recommended Posts

  • 1

Hi Veda,

 

Thank you for your reply. 

 

Finally, we found out the problem some DLL blocked issue. The problem caused by some unknown DLLs as a network services layer replied Citrix receiver network request but didn't provided valid socket binding services. Uninstall the problem software agent, Citrix receiver resume to normal.

 

So, the problem not relate to Citrix receiver, windows patch updated or windows security setting issue.

 

  • Like 1
Link to comment
  • 0

Hi Veda, 

 

Thank you for your reply.

 

Yes, for VDI, Nestcalar is used for connection.

Session reliability connection for non-problem user is available. But these mention problem users PC, even click a published application or open VDI desktop, checking Citrix receiver connection center no any session was established. So, finally, no xenapp or VDI could be launch until timeout.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...