Jump to content
Welcome to our new Citrix community!
  • 0

Possible Workaround: Citrix Receiver X Error on Linux Thin Clients

Manoj Biswal


We have a setup where we use IGEL Linux Thin Clients on Windows 2012 Citrix Servers. To be specific, we use IGEL UD3 LX42 and LX50 as our endpoint devices.


After the recent 7.15 patches, we started getting the following Citrix Receiver Errors on our Thin Clients,


"The X Request 55.0 caused error: "9: BadDrawable (invalid Pixmap or Window parameter)"

"The X Request 60.0 caused error: "13: BadGC (invalid GC parameter)".


We encountered these errors on Linux OS Thin Clients only and we had no issues with Windows Clients/PCs.


As far as the Citrix Receiver is concerned - we had devices on various versions of Citrix Receiver .i.e. 13.2, 13.3, 13.7 but none of that helped.


To tackle the issue, we made the following changes on the Thin Clients,


Modify Registry > ica > forceignorexerrors > Activate ‘Suppress X error message boxes’

Modify Registry > wfclient > ignorexerrors > Activate and pass the following parameters, 55.0/9, 60.0/13


We are yet to understand the cause but the above solution has been holding up well. We are monitoring the devices.


Hope this helps!

Manoj KB


Attachment: Error Screenshot


Error Screenshot


Link to comment

7 answers to this question

Recommended Posts

  • 0

If anyone comes across this thread, the solution that worked for me was to edit the wfclient.ini file and add
to the [WFClient] block the string "IgnoreXErrors=55.0/9,60.0/13"



- XUbuntu 18.04

- Firefox v52 browser
- icaclient    amd64  Citrix Workspace app for Linux


# vi ~/.ICAClient/wfclient.ini


Version = 2
KeyboardLayout = (User Profile)
KeyboardMappingFile = automatic.kbd
KeyboardDescription = Automatic (User Profile)

. . .



DesiredHRES = 640

. . .




Link to comment
  • 0

I just come on this issue myself



- Ubuntu 18.04 bionic (x86-64)

- Firefox v77 or Chrome v68 browsers
- icaclient  amd64  Citrix Workspace app for Linux


I've been using this for 3 months now and it just stop working without any system/browser/icaclient update


I tried previous advise with IgnoreXErrors in wcclient.ini but didn't change anything.


I even tried to add a ForceIgnoreXErrors=True based on what said on previous post but still fail


Isn't there any Citrix dev able to fix this very old issue ??

Link to comment
  • 0

After uninstall/reinstall of the icaclient it started working again.


I did it the hard way that is to say I manually deleted /etc/icaclient and ~/.ICAClient because uninstalling icaclient was not doing so.


I reinstalled with a:


sudo dpkg -i --force-all ./Downloads/icaclient_20.04.0.21_amd64.deb


don't forget the --force-all


But it would still be better to fix it properly, I hope I won't have to go through this again.


It looks like something got corrupted in icaclient file at some point.

Link to comment
  • 0

We are having this issue with the last few versions of IGEL firmware, we never had it until then but it started occurring for us within the last few months. We're attempting to get IGEL to look into the issue but they are pointing fingers back at Citrix.

Is there a reason why displaying X errors is the default behavior of Linux Workspace, and why we have to disable each error individually? This is a poor user and administrator experience and it makes much more sense to have this as an opt-in rather than opt-out setting, since this information would not be useful to the vast majority of users/admins unless they were specifically looking for debug info. I also don't want to have to figure out every single X error that a user might experience to include it in this setting, not to mention that it seems to be very difficult to find a comprehensive list of X.Org error codes.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...