Jump to content
  • 1

Users unable to reconnect to disconnected sessions

Rick Culler


XenDesktop 7.15 CU1 - Pooled random desktop group

Receiver 4.9 CU1

Windows 7 VMs


Running into an issue where some users will disconnect from their VM session either at the end of the day or when they go for lunch, and upon returning, sometimes they cannot reconnect back to their session. Desktop Director shows it as a Machine Failure, and upon looking at the details, it shows that the user's session state is still active. At this point only solution to get the user up and running is either have the user initiate a restart of their virtual desktop, or have the helpdesk log the user off, or send a restart command to that virtual machine.


I haven't been able to replicate it unfortunately, and I haven't been able to determine a pattern to when or to who it happens to. Only consistency I've seen is that the users are disconnecting, but the VM still thinks the session state is active.


Anyone seen anything similar or have any ideas?

Link to comment

25 answers to this question

Recommended Posts

  • 0

Sorry, should have included that info to begin with.


yes, PVS 7.15 CU1 and NVIDIA Grid K1 cards using K120Q vgpu profile.


No, I have not opened a support case yet, as we do not have a support agreement in place, so I wanted to see if there was an easy answer first, before paying to open a ticket.

Link to comment
  • 0

I have a feeling this issue might be tied with Receiver 4.9 CU1. We recently went through upgrading all of our managed clients to 4.9 CU1 from a variety of other older versions. Since then, this is when we started to notice this trend, it just wasn't apparent, since we didn't upgrade them all at once, and we didn't suddenly see any real spikes in connection errors on Director.

Link to comment
  • 0

Still no update on my side. I looked at the event logs on some of the affected VMs, and there is no errors. However according to the VM logs, the VM is unaware of when the user actually disconnects from the session. It isn't until I intervene on an affected machine does it register the session as disconnected.


We have about 500 Windows 7 machines, and about 25 Windows 10. Have only seen it happen on Windows 7. Could be due to the fact of only having a limited number of Win10 machines.


Out of curiosity, we are using vGPUs for all of our VMs, is this happening to anyone NOT using vGPUs?

Link to comment
  • 0



Same issue here, we also opened a citrix case (#77096643) we can find the following events on our controllers:

The issue seems related to users using 4.9.1000 Citrix receiver in our case, session state stays connected


The Citrix Broker Service failed to broker a connection for user 'USERNAME' to resource 'VDI workspace'. The virtual machine 'DNSnameof.machine' rejected a request to prepare itself for a connection. This problem usually indicates that the virtual machine is engaged in an activity such as restarting, entering a suspended state, or processing a recent disconnection or logoff. 

Link to comment
  • 0

Hey i had the same issue with shared desktop and it got resolved after disabling the legacy graphic mode .


But , right now its an issue with just one server , could not reconnect to the session after disconnecting . Cannot disconnect or log off the session from the Task Manager too .

Link to comment
  • 0

I'm seeing this issue in Windows 10 on both 7.15 CU2 and CU3. Oddly, I'm only seeing this in one of our farms, and not the other, which makes me think there may be a server-side configuration difference.  I'm checking to see what I can find.Seeing this issue in Windows 10 on both 7.15 CU2 and CU3. Oddly, I'm only seeing this in one of our farms, and not the other, which makes me think there may be a server-side configuration difference.  I'm checking to see what I can find.


EDIT:  I noticed that the session in question is not showing the username connected to the session in Studio, so I think it may be related to that issue.



Link to comment
  • 0

Reinstalling the 7.15 CU3 VDA resolved the issue for me on the machine in question.  The only thing I did differently this time was installing Windows Media Player because I was getting the message the Windows Media Foundation was not installed.  I had to install it via the older Programs and Features applet in Control Panel.  I'm not sure that this was related to the issue I was having.  It's possible that uninstalling and reinstalling the VDA was the fix, but this was a variable.  After the reinstall, Studio was showing my username as the connected user instead of the "-", and after that reconnections worked.



Link to comment
  • 0

Hello , 

do we have answer for the above query , 

On xendestop 7.15 , users are disconnecting their session while going breaks and expectation is while the come back and try to launch they should get same desktop session but this is not happening , they been routing to next available VDI , 

Any quick solutions please  


netscaler 12.1 build 57. 3 

xendestop 7.15 


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...