Jump to content
Welcome to our new Citrix community!
  • 0

Silent install gets stuck


Niels Geursen1709157675

Question

Currently we are running Citrix XenApp 7.9 (No updates) on Windows 2008R2 (Physical install) and we would like to upgrade towards XenApp 7.15 LTSR CU1. When upgrading the VDA installation towards 7.15 LTSR from within an admin session the installer just finishes without any issue with all the required reboots.

When using the same installer and  trying to automate (/silent option or the /Quiet) the installation with all the correct command line parameters (Same as the 7.9) the installation gets stuck on the ICAWebWrapper.msi. Logs show that the installation is finished however the executable is not closed when checking the taskmanager. The installation is not continuing.

All prereq's are installed.

 

Did someone had the same issue?

 

If information is missing let me  know and I will do an update.

Link to comment

5 answers to this question

Recommended Posts

  • 0

We found a solution for this problem. We are currently using a deployment tool which will install the software with permission of a service account. This failed. The installation gets stuck.

We then installed the receiver under the System Account and the problem was solved. We used PSEXEC to be able to run under the system account.

For more information please check the following blog: silent install citrix receiver not working

 

Maybe Citrix could change this in the installer?

  • Like 1
Link to comment
  • 0

We have tried below steps with both physical and VMs but not reproducible. please provide more details.

 

  1.  Install 7.9 VDA using command: \x64\XenDesktop Setup\XenDesktopVdaSetup.exe /quiet /components VDA /controllers "<XXXX.COM>"/enable_remote_assistance /enable_hdx_ports /optimize /enable_real_time_transport /masterimage /virtualmachine
  2.  Upgrade to 7.15 CU1 and CU2 VDA using same command parameters. It is successful.
Link to comment
  • 0

The installation of only the VDA is working without any issues.

 

However the Receiver is not installed. We would like to install the Receiver as well. When using a standalone installer with the command: /AutoUpdateCheck=DISABLED /includeSSON /ENABLE_SSON=Yes /EnableCEIP=False /allowaddstore=N /silent /noreboot

The installation gets stuck on the ICAWebWrapper.msi.

Link to comment
  • 0

We had checked upgrading 7.9 VDA with receiver to 7.15 CU1 VDA with receiver on 2K8R2 using 2 methods as below, upgraded successfully.

 

1.       Using command line to install VDA along with receiver.

\x64\XenDesktop Setup\XenDesktopVdaSetup.exe /quiet /components VDA,plugins /controllers "<xxxx.com>"/enable_remote_assistance /enable_hdx_ports /optimize /enable_real_time_transport /masterimage /virtualmachine

 

2.       First install only VDA using command line, then install receiver using command line.

Install only VDA: Install 7.9 VDA using command: \x64\XenDesktop Setup\XenDesktopVdaSetup.exe /quiet /components VDA /controllers "<xxxx.com>"/enable_remote_assistance /enable_hdx_ports /optimize /enable_real_time_transport /masterimage /virtualmachine

Install receiver: \Citrix Receiver and Plug-ins\Windows\Receiver\CitrixReceiver.exe /AutoUpdateCheck=DISABLED /includeSSON /ENABLE_SSON=Yes /EnableCEIP=False /allowaddstore=N /silent /noreboot

 

please check if anything missed here..

Link to comment
  • 0

We're needing a little bit of help here as well. The objective is to install the VDA on a Windows 2012R2 server using the 7.15 LTSR CU4 that we downloaded from Citrix and have it on the server:

 

VDAServerSetup_7_15_4000.exe /quiet /masterimage /components vda /disableexperiencemetrics /exclude "Personal vDisk","Citrix Personalization for App-V - VDA" /enable_hdx_ports /enable_real_time_transport /optimize /noreboot

 

From what we've read there in no need to add controllers if we'll be using MCS later, which we'll be doing.

 

By default Personal vDisk and Citrix Personalization for App-V - VDA and installed so we're hoping the /exclude line will stop that from occurring.

 

We opened a case with Citrix support about this a few months ago and one thing we would have liked to have seen after the installation via CLI is someplace to verify that the components we want to exclude are not installed and also that the features we enabled are indeed enabled.

 

Help would be greatly appreciated.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...