Jump to content
Welcome to our new Citrix community!
  • 4

Keyboard shortcuts (CTRL+SHIFT + ARROWS) do not work on Citrix Receiver v4.6 and anove


Sandeep Pandit

Question

Hi,  I recently updated my Citrix Receiver client from v4.5 to v4.10.x and noticed that keyboard shortcuts such as CTRL+SHIFT+ ARROWS to select words / text stopped working. I have not been able to find any configuration settings to enable these shortcuts to work. I reverted all the way to v4.5 having tried v4.9 and back... until it started working again in v4.5. However the issue with v4.5 is the mouse / cursor freezes from time to time and jumps... 

 

Has anyone noticed this issue with keyboard shortcuts or can offer any suggestions? I use Windows 10 Home operating system and work remotely to connect to our office Citrix desktops. 

 

Cheers.. 

Link to comment

8 answers to this question

Recommended Posts

  • 0
12 hours ago, Aldo Zampatti1709152545 said:

Quoting myself here, but Linux's receiver works as expected with control+shift+tab and ctrl+shift+arrows, this is just Windows Receiver-related.

And as I said in my previous post, shortcuts work with my computer with Windows 7 Enterprise but not with my Windows 10.

I wish someone from support could hear us... I tried the webchat but it seems that it's never available.

Link to comment
  • 0

This is an old topic but for me it is caused by Local IME in the preferences drop down, if it is set to "Set local IME to Best Experience mode" it enables a hotkey Shift + F4 which locks out being able to use shift + alt in your session. 

 

Setting it to Enable Server IME, allows me to use alt + shift + arrow keys

Link to comment
  • 0

2nd half of 2022 and I was fighting this for hours. For me, disabling keyboard sync via the GUI didn't fix the issue.  I had do it in the registry according to https://admx.help/?Category=CitrixWorkspace&Policy=receiver.Policies.receiver::Policy_Keyboard_Settings_1.

In case that link dies:

HKEY_CURRENT_USER\Software\Policies\Citrix\Ica Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard

1. Set LocalIME to: 0

2. Set KeyboardSyncMode to, and this is a string literal, not a placeholder: (User Profile)

 

Though for me it was in Software\Citrix, not Software\Policies\Citrix.

 

Voila, I don't need to disable my windows key passthrough to reliably Ctrl+C now.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...