Jump to content
Welcome to our new Citrix community!
  • 1

Server 2016 Start Menu


Simon Magee1709159107

Question

I am facing an issue with my WEM pinned Start Menu icons. - They are not appearing!

 

I have set several applications to pin icons to the Start menu and some to the desktop, the desktop icons are appearing correctly and sometimes I might get one or two appear in the start menu.  If I remove the users UPM profile and logon all my icons appear. Also if I de-select the "Hide Common Programs" option in WEM they appear along with the icons I want to hide from users,

 

I'm using WEM 4.5, XenDesktop 7.15 LTSR with Server 2016, User profiles are configured trough WEM but using UPM.

 

Thanks

Simon

Server 2016 Start Menu.PNG

Link to comment

5 answers to this question

Recommended Posts

  • 0
On ‎02‎/‎02‎/‎2018 at 11:13 PM, James Kindon said:

That option in WEM has very odd results in different environments. I’m now firmly of the view to ignore it and pretend it doesn’t exist in server 2016 and windows 10. 

 

The GPO option leads to better results, the other neat way is to remove “read” permissions on the %programdata% based location for the start menu for “users”. This way they cannot read that location and no start menu defaults are populated from there 

 

for UPM, it shouldn’t be a problem if configured ok - I have a module that seems to be ok if choosing to use WEM to drive upm 

https://jkindon.com/2017/11/27/citrix-upm-module-for-the-wem-hydration-kit/

 

I am getting better results now I am using WEM to complete my Folder Redirection rather than GPO.  I have a feeling GPO and WEM were having a fight and WEM was loosing!

  • Like 1
Link to comment
  • 0

That option in WEM has very odd results in different environments. I’m now firmly of the view to ignore it and pretend it doesn’t exist in server 2016 and windows 10. 

 

The GPO option leads to better results, the other neat way is to remove “read” permissions on the %programdata% based location for the start menu for “users”. This way they cannot read that location and no start menu defaults are populated from there 

 

for UPM, it shouldn’t be a problem if configured ok - I have a module that seems to be ok if choosing to use WEM to drive upm 

https://jkindon.com/2017/11/27/citrix-upm-module-for-the-wem-hydration-kit/

Link to comment
  • 0

I located this KB article: https://support.citrix.com/article/CTX225233 which suggests the issue can be caused by the users profile has not fully loaded and become ready by the time WEM Agent launches, so only creating some Start Menu icons instead of all.  It suggests increasing the "Agent Extra Launch Delay (ms)" from the default value of "0" to "10000".

 

I have just completed some further testing and been getting consistent results.

Link to comment
  • 0

Interesting that you needed to change that value - usually UPM when tweaked is fast enough to not need that changed - good that its working though

 

5 hours ago, Simon Magee1709159107 said:

I have a feeling GPO and WEM were having a fight and WEM was loosing!

Yep, always one or the other, else last write can win

Link to comment
  • 0

Hi James:

 

I have this same issue:  I have a UAT group of Server 2016 machines, and WEM 1912 LTSR configured to add Apps to the Start Menu.  If I delete my Test account, when it creates the Profile (on the Share) the first time, the Apps show up fine.  The next logon, however, shows the same Start Menu as show above in this thread.  Per the UPM Module you linked to, on the main "Notes" page there, I have disabled "Active Write-Back" and "Active Write-Back Registry" for that UAT Configuration Set.  I have also made sure the "Agent Extra Launch Delay (ms)" has a Value of "10000"...

 

I tried increasing it to 20000, just to see if that would help, but it didn't.

 

Any thoughts on this?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...