Jump to content
Welcome to our new Citrix community!
  • 0

Printer Assignment - Cannot add or edit more than 20


Anthony Yates1709157372

Question

Recently upgraded our environment from 7.15 to 7.15.1 (CU1) and have just noticed that we can no longer view or modify our existing Printer Assignment policy.

 

When we go to edit the policy the columns seem to expand in size and the window grows very wide. Depending on how many printer assignments you have configured this can happen quickly or over a few seconds before the window settles down.

For our policy we have 159 printer assignments and once the window has populated the columns appear to have grown too wide and I cannot see or access the scroll bar to move down the list. The other main issue though is that all the entries for the Session Printers column are blank. If you attempt to edit an existing assignment it also shows blank.

 

If I create a brand new policy, the window still does the weird expanding thing, but I can create an assignment, save it and also go back in and edit it and the entry is still there. However I can only add about 20-21 assignments. After that the Add button, Search box and Help description all drop off at the bottom of the window and are no longer accessible.

 

Today we've also had a few reports about certain printers not being assigned, however without being able correctly view the existing policy I cannot confirm if this is related (ie printers assigned but not actually applied) or if this related to another change we applied to remove printers all network printers at logoff so they only get printers currently assigned to them (stops build up of printers if users move between sites).

 

Looking at the fixed issues for CU1 it looks like there were a bunch of fixes for Printer Assignment but obviously not tested very well as it appears to have broke more than its fixed.

 

It should also be noted that I've attempted to edit the policy from the Delivery Controller server (7.15 CU1) as well as AD server we're we've also tried installing Citrix Group Policy Management 3.2 (from 7.16).

 

I'm probably now going to see if I can install the previous Citrix Group Policy Management from 7.15 on another server to see if I can at least view the existing policy because maybe I can then recreate the entries in multiple policies of less that 20 assignments until the issue is resolved.

 

 

 

PrinterAssignmentIssue1.JPG

PrinterAssignmentIssue2.JPG

Link to comment

6 answers to this question

Recommended Posts

  • 0

Well although I'm disappointed that not one person or Citrix could verify this issue, I'm happy to report that 7.15 LTSR CU2 has resolved the issue.

 

"Using Citrix Group Policy Management 3.1 to add the Printer Assignments setting to a User Policy in Active Directory might cause a window resizing issue. The window might begin to auto resize horizontally after you open it until it extends to the corner of the screen. As a result, editing the policy can be difficult because you cannot reach all of the columns. [#LC8684]"

 

  • Like 1
Link to comment
  • 0

Ok further update.

 

It does appear that all session printers were wiped from the policy but its not clear exactly how that happened as it occurred prior to the upgrade to 7.15 CU1. We had noticed that our AD servers had older versions of Citrix Group Policy Management a few days before we upgraded to CU1 and updated those to latest version. During that particular update we did have the issue where if you didn't also install the 2015 Visual C++ redistributable you couldn't open the Citrix policy at all. Also initially we only installed the x64 Visual C++ which resolved us opening the policy but when editing the policy it resulted in different errors, can't remember exactly but something related to a buffer error. We then noticed the Delivery Controllers had the x86 and x64 versions of 2015 Visual C++ redist, so we installed the x86 version as well and that resolved the error editing the Citrix policies.

So my theory is that during that process we've opened the Citrix policy and because it wasn't loading/saving correctly it's saved back a partial policy and wiped the session printers.

 

Anyway, so we got the session printers back into the policy now by restoring the policy from a backup and I've checked that editing the Citrix policy does not result in the printer assignments being wiped.

 

The original issue still stands though, we cannot correctly edit our existing policy because once you have more than 20 assignments there is no way to scroll down to the other assignments.

 

Link to comment
  • 0

And another update.

 

So I think I worked out how the printer assignments got wiped. I installed the previous version of Citrix Group Policy Management (v3.1 from 7.15) on a separate server to see if I could at least access and view the full list of printer assignments and what I found is that again I had 0 session printers assigned to my 159 printer assignments. I then checked what it showed on the servers with the latest version of the console and it still showed the 159 session printers.

So it looks like there is an incompatibility between the two versions and if the policy was edited in the wrong version it wipes out the session printers.

 

The other thing I noticed is that even with v3.1 (7.15) of the Citrix Group Policy Management the weird expanding window and inability to scroll down also exists in this version to. So this issue is probably not a direct result of the update to 7.15 CU1.

I think because we were always editing the Citrix policies from our AD server, which at the time had older versions of Citrix Group Policy Management installed, we've only just come across this issue. When you edit a specific printer assignment this now appears in a separate window with three tabs for Client, Session Printer and Default Printer. When we were editing them before all the editing was within the main printer assignment list, which was horrible so glad that improved, but looks like this scrolling down past 20 printer assignments occurred whenever this new UI for printer assignment appeared.

 

Given that fact I'm surprised its not been picked up before now.

 

Looks like I'm going to have to do what I originally suggested and move our 159 printer assignments into separate policies/blocks of 20 or less.

 

Link to comment
  • 0

Can anyone else confirm if they have this issue?

Can you add more than 20 entries without the whole window going weird and moving Add button beyond the bounds of the window and providing no scroll bar?

Or does everyone else just not bother using Printer Assignments and uses some other method instead?

 

image.thumb.png.4ee09385f95bfc7e679e4d5fabfa939c.png

Edited by ayates527
Added descriptive picture of issue
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...