Jump to content
Welcome to our new Citrix community!
  • 0

VIF?


Kent Soumlderlund

Question

Hello!

Have 4 XenServer. Not pooled. No shared storage

In XenCenter, if I right click a VM and choose "Move" or "Copy" I get different results depending on server the VM is on:

XenServer 1 & 2 - no problem. All other XenServers is possible as target

XenServer 3 - if I right click the VM, all target have the text (and are greyed out) "This VIF is not mapped to a destination network"

 

???

 

All help appreciated / Kent 

Link to comment

16 answers to this question

Recommended Posts

  • 0

Didnt help :( (I dont try to do live migration, I want to do offline migration)

But now I see some other strange thing:

XenServer 1 - can move any VM to any host

XenServer 2 - can move any VM to any host

XenServer 3 - 

  Try to move VM 1 - No problem

  Try to move VM2 - only possible to move to another storage on the same server., Thats the only option I get, not the option to move to another host.

  Try to move VM3 - gets "This VIF is not mapped to a destination network"

 

I realize something is wrong in this server setup, but what?

 

/Kent

Link to comment
  • 0

Is the subnet network for that VM not translating correctly to one or more of the other hosts? Have you tried to use the migration wizard and specify a different

network for the migration (the default is the primary management interface)? I would suspect that the issue has to do with there being no corresponding subnet for the VM on the destination XenServer host.

 

-=Tobias

Link to comment
  • 0

Click on the VM (should be running), => Migrate To server => Migrate wizard (at the bottom of the menu). You should then get the option to pick various parameters, like the destination, migration network, etc.  I believe you may need a paid-for edition to be able to tap into this, depending on what version of XenServer you are running. In this case, this is XS 7.1 Enterprise.

 

-=Tobias

 

CaptureMW.JPG

Link to comment
  • 0
On 6/3/2022 at 6:27 AM, Iulian Casian Merce said:

even if the topic is super old, I still want to post it for the record.

 

I had the same issue today:  "This VIF is not mapped to a destination network"

 

In my case all the settings were ok, but the cause seemed to be that the VM had a snapshot. As soon as I deleted the snapshot, it worked.

 

 

A true internet Hero! This solved it for me, thank you!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...