Jump to content
Welcome to our new Citrix community!
  • 1

ALT-TAB on the remote computer


Sajjan Janardhanan

Question

I am having the classic Alt+TAB issue with my laptop that runs Windows-10

The ALT-TAB works on the local machine and not on the remote machine

The remote machine runs Windows-7 and has Office 2010 installed

 

I had learnt from my prior experience that this can be fixed with an update to the local computer's registry; steps listed below

  1. Open regedit on the client device to edit the registry
  2. Navigate to the key
  3. HKEY_LOCAL_MACHINE \SOFTWARE\Citrix\ICAClient\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard\
  4. Open Key: TransparentKeyPassthrough
  5. Set the value to: Remote 

 

However, I could not find the following keywords in my registry, so didn't know where to make the update.

  • citirix
  • icaclient
  • transparentkeypassthrough

 

I even reinstalled the Citrix Receiver client from the Windows App Store, but that didn't help.

 

The support-info option in the client gave the following info -

<?xml version="1.0" encoding="UTF-8"?>
<Diagnostic version="1.0">
  <Receiver-Store version="4.10.11.0">
    <Plugin>
      <Name>Citrix Receiver Store</Name>
      <ID>{8C92B884-C818-45D0-A757-7123B78AA247}</ID>
      <Version>4.10.11.0</Version>
    </Plugin>
  </Receiver-Store>
</Diagnostic>

 

I am so tired of having to use the mouse every time I have a need to switch windows in my remote machine.

Please comment if you have a fix.

 

PS: I have an older computer that also runs Windows-10, but I was able to get the ALT-TAB working with the registry update. However, not it in my new laptop for reasons described above.

Link to comment

2 answers to this question

Recommended Posts

  • 1

Hi sajjanj,

 

I thought we're in the same boat, I was searching for a solution, with the same outcome, coudn't find the path in regedit as well, then I found that, and it worked:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard

“TransparentKeyPassthrough”=”Remote”

 

I hope it does the trick for you as well.

 

Raphoooo

 

  • Like 1
Link to comment
  • 0

I figured that there are multiple citrix products; I was facing the issue of not finding registry entries when I was using Citrix Workplace however when I installed Citrix Receiver I was able to find the registry entries and was also able to enable ALT + Tab with my Win 10 client laptop.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...