Jump to content
Welcome to our new Citrix community!
  • 0

Hangs at Provisning Services screen and then BSOD (cvhdmp.sys)


David Jackowiak1709156252

Question

Hello,

 

Everything was up and running before upgrading to XenApp 7.15 (including Provisning Services 7.15). We have created new vdisk version, upgraded PVS target device, reboot and then VDA to 7.15 and reboot. Everything was great. Promoted to production. Up and running. Then there was a time to update vdisk (new shortcut on desktop for users) so no big changes here. Took reboot just in case (like always) and boom - hangs on Provisning Services 7.15.Xxxx and after 10 second - BSOD cvhdmp.sys. So we decided to delete this version and create new one. Booted great but this time we just logged on and streight reboot without any changes - boom the same problem. Interesting thing is that if I DO NOT logon and just reboot on logon screen, I can then boot like always. It seems that after I logon, no mater what if I do some changes or just reboot the server, I get BSOD system_thread_exception_not_handled (cvhdmp.sys). 

 

I dont know if it is important but we have moved all cache disk to another storage after upgrading

 

I have even tried to delete some versions and go back in time to f.ex. version created 3 months ago - the same ting. Boots up, reboot BEFORE logon (on logon screen) - can boot again. BUT if I logon no matter if with local user og domain user - Reboot -> BSOD.

 

Never ever had seen this before. I have no idea if its related to XenTools or something. We haven´t had those issues BEFORE upgrading PVS and target device to 7.15. Never. 

 

I have tried everything I can find here. 

 

IPv6 disabled in Windows and GPO (disabled components)

XenTools up and running - no errors in XenServer

Tried to remove ghost NICs - no luck

 

 

I have also upgraded PVS to 7.16 with strong feelings that updating would have fixed our problem. Then went to new vdisk version, booted up, updated Target device software and with hope - reboot server to finish installation but it HANGS again on Provisning services 7.16.XXX and then BSOD. It doesn't pass to target IP and Server IP. It hangs straight away on Provisning Services 7.16.XXXX and throw BSOD after some seconds. 

 

Any ideas? It would help us and save our days.


Thanks guys.

Link to comment

5 answers to this question

Recommended Posts

  • 0
31 minutes ago, shocko said:

A couple of questions:

 

  • What version did you upgrade from?
  • PVS Target is what OS?
  • Since logging in seems to cause the issue, can you run a procmon trace to see exactly what's getting committed to the version?

 

 

1) from XenApp 7.11

2) Server 2016 patched with MS October CU

 

Any ideas what it can be? I went thru every documents I have on changes committed related to users (GPO) to see if it has something to do with some GPO or regisrty settings but We haven't do so much changes since 7.11 some small fix related to f.ex. wallpaper but I have testet without user GPO. Same problem. Dont't know where there problem is but it doesn't work with Local user ether so It can't be GPO.

 

 

UPDATE:

 

I have now tested BEFORE logging into new version in maintenance right after reboot. I just have waited some time and took straight reboot without logging inn. Doesn't work so it has nothing to do with user. It have to be something which loads up og changes while in maintenance. 


One thing I can see when I go to device manager that in the production version which is work, I can clearly see something like this attached in picture

 

Production.PNG

 

 

BUT when I go to device manager on the new version of the same vdisk in maintenance mode it is then:

 

XenServer PV Network Device (WITHOUT #0)

 

and the under I have some XenServer PV Network Device WITH #0 but active is the one wothout #0.

 

Is it something here? 

Link to comment
  • 0

 

I would suggest setting up to collect the crash dump refer to https://support.citrix.com/article/CTX123642  

 

Moving the storage may have something to do with it but there is not enough information to be sure, I would turn target side debugging and create a problem report using the https://docs.citrix.com/en-us/provisioning/7-11/install/cis-problem-reporting.html  after collecting the crash dump call support. 

 

Carl

 

 

 

Link to comment
  • 0

This seems to be the same Problem which i'm facing right now.. but when i did reverse imaging and reinstalled XenTools i'm getting an "PV Storage Host" message which wants me to restart. I got this message bevor on lokal hdd after the installation and restartet it more than once - but after logging in to the new vdisk this message appears again. Once i received this message BSOD is showing up again after the restart.. 

 

I already have an open ticket with Citrix support but neither me nor them was able to collect a memory dump in this case. 

 

Any suggestions what i could try?

 

i got more information about my issue here!

 

Tim

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...