Jump to content
Welcome to our new Citrix community!
  • 0

Icons white/blank on the desktop for Published Applications


Jan Cauwenbergh1709152054

Question

Hello,

 

We publish a XenApp 7.11 desktop to users.  On the desktop of this session we publish applications via sso.  At logon, these icons get created fine, no problem.  But, after  X minutes all those icons go blank/white, but keep working.  Happens most of the time, not always, to make it easier...

 

To save everybody time,this is already in place:

Computer Configuration / Administrative Templates / Windows Components / File Explorer
Allow the use of remote paths in file shortcut icons

 

Found already this in the forums, but no cigar:

 

https://discussions.citrix.com/topic/368858-published-application-icons-missing-through-netscaler/
https://discussions.citrix.com/topic/372617-icons-blank-although-they-work/
https://discussions.citrix.com/topic/366092-problem-with-icons-on-the-desktop-for-published-desktops/
 

 

These are also old posts. 

 

In the selfservice log I do not find any pointers.  Icons are 48x48 btw.

 

Any idea would be welcome.

 

cheers,

Jan

 

 

 

 


 

Link to comment

7 answers to this question

Recommended Posts

  • 0

I get something similar when using the newer clients but with XA6.5, WI 5.4.  We content redirect the users Desktop, but not AppData.

 

Carl, are you aware of a way of getting pub app creation to go back to being within the historic locations of the users profile instead of with the .exe which I think the newer agents do ?

Link to comment
  • 0

Reason has been found:

 

When Citrix receiver refreshes the icons, it creates shortcuts on the desktop and icon files in %appdata%\Citrix\SelfService\Icons. The icon files saved in that location have a unique Timestamp on it.

The desktop of the users is redirected to \\xxxxx\mydocs$\%username%\desktop
Since it’s redirected, changes to the desktop are immediately saved to the central location on the fileserver

The %appdata% part of the profile is not redirected but is saved in the roaming profile.
The roaming profile saves to the central location (fileserver) when the user logs off.

 

On day x, the user is logged on and the Citrix refreshes the icons.

shortcuts on the desktop are replaced and those shortcuts are getting their .ico icon from %appdata%\Citrix\SelfService\Icons\<programname><TIMESTAMP>.ico

The user on that is not logging of correctly (can be the user his or her own fault, or another reason could be that the server crashes that day and we have to reboot it)

At that moment, the shortcuts on the desktops point to %appdata%\Citrix\SelfService\Icons\<programname><TIMESTAMP>.ico but those files are not saved in the roaming profile
à white icons are displayed

Link to comment
  • 0
On 2/23/2018 at 10:16 AM, Jan Cauwenbergh1709152054 said:

Reason has been found:

 

When Citrix receiver refreshes the icons, it creates shortcuts on the desktop and icon files in %appdata%\Citrix\SelfService\Icons. The icon files saved in that location have a unique Timestamp on it.

The desktop of the users is redirected to \\xxxxx\mydocs$\%username%\desktop
Since it’s redirected, changes to the desktop are immediately saved to the central location on the fileserver

The %appdata% part of the profile is not redirected but is saved in the roaming profile.
The roaming profile saves to the central location (fileserver) when the user logs off.

 

On day x, the user is logged on and the Citrix refreshes the icons.

shortcuts on the desktop are replaced and those shortcuts are getting their .ico icon from %appdata%\Citrix\SelfService\Icons\<programname><TIMESTAMP>.ico

The user on that is not logging of correctly (can be the user his or her own fault, or another reason could be that the server crashes that day and we have to reboot it)

At that moment, the shortcuts on the desktops point to %appdata%\Citrix\SelfService\Icons\<programname><TIMESTAMP>.ico but those files are not saved in the roaming profile
à white icons are displayed

 

Hi

 

Can I ask what you did to resolve the issue? I am experiencing the exact same thing and trying to avoid purging thousands of profiles

 

many thanks

 

Link to comment
  • 0

Maybe late to join this discussion, but I was having the same issue and all which the OP said is true.

 

Doesn't look like this is the case here since OP problems seams to be losing the icon but others can come here searching for blank icons and here is something to check:

 

Windows Server, at least the 2012 /2012 R2(maybe later versions),  by default blocks icons from remote locations (i.e: Shared Folders, Folder Redirection, UPM).

You need to configure the policy stated in the article below:

https://support.citrix.com/article/CTX204247

 

Computer Configuration / Administrative Templates / Windows Components / File Explorer
Allow the use of remote paths in file shortcut icons

set this to Enable

 

You can create a GPO using AD, you don't need to set this locally at the server as the article sugests.

 

Another thing that may help is importing the Receiver.admx (which you can obtain in C:\Program Files (x86)\Citrix\ICA Client\Configuration) and setting:
Computer Settings>Administrative Templates>Citrix Receiver>SelfService:
Manage App Shortcut

 

Open, Enable and check the boxes "Remove apps on Logoff" and/or "Remove apps on Exit"

This way, possibly it will remove the shortcuts on logoff/exit(of the Receiver not the Windows Session) and will point to another created icon with the other timestamp at next logon.

 

Also, for heavily bugged users you can:

Logged on with the affected user Right Click Receiver > Advanced Preferences> Reset Receiver, instead of reseting the profile

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...