Jump to content
Welcome to our new Citrix community!
  • 0

Microsoft Hyper-V Generation Counter disabled


Boris Schurmans

Question

Hi,

 

We are running server 2016 as xenapp 7.15 hosts with app layering 4.5 on Xenserver.

 

We noticed that in Control Panel --> Devices and Printers --> Devices --> 'local machine name'  there was a yellow exclamation mark.

When opening the properties we see that it's caused by the 'Microsoft Hyper-V Generation Counter'.

 

It says "a driver (service) for this device has been disabled. An alternate driver may be providing this functionality".

 

Can this be ignored since we are using Xenserver? We used the Citrix Optimizer script provided by Citrix for optimizations. Is this something that the script disables maybe?

 

Regards

Boris

Link to comment

3 answers to this question

Recommended Posts

  • 0

I also see the yellow troubleshoot alert in Devices and Printers on Windows Server 2016 with 1909 and 1912.   I found that the "Microsoft Hyper-V Generation Counter" hidden in device manager because the registry value 4 was set for "Start" under HKLM\SYSTEM\CurrentControlSet\Service\gencounter. 

 

I set this value back to 3 in the OS layer which changes the service type to manual.  This resolved the troubleshooting alert and hidden device in device manager for just that layer.  However, I deployed the next layer and the value was set back to 4 so I assume Citrix App Layering is disabling this service.

 

Can someone confirm if disabling the service is required by Citrix App Layering?

Link to comment
  • 0
On 2/11/2020 at 10:23 AM, LEVI PINGEL said:

I also see the yellow troubleshoot alert in Devices and Printers on Windows Server 2016 with 1909 and 1912.   I found that the "Microsoft Hyper-V Generation Counter" hidden in device manager because the registry value 4 was set for "Start" under HKLM\SYSTEM\CurrentControlSet\Service\gencounter. 

 

I set this value back to 3 in the OS layer which changes the service type to manual.  This resolved the troubleshooting alert and hidden device in device manager for just that layer.  However, I deployed the next layer and the value was set back to 4 so I assume Citrix App Layering is disabling this service.

 

Can someone confirm if disabling the service is required by Citrix App Layering?

 

We are using the updated 2112 version of AppLayering and we are still seeing this is this something that can be ignored?  We have been troubleshooting our boot times and this is just one of a few items we have found.  However, I did find this link and set it and now the device works Microsoft Hyper-V Generation Counter (gencounter) Service Defaults in Windows 10 (revertservice.com).

Edited by SCOTT LORENZEN
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...